PDA

View Full Version : SMB share file permission problems




adarkenigma
Aug 22, 2013, 02:37 AM
Hello, I have smb share running on mac mini server. problem is that file created by smb user can't be accessed by anyone else other then file owner.
file created on same share (folder) by afp user has no problem. I tried giving full permission to folder chmod 777 but to avail.

I want file created by smb user to have no ownership so other programs can access file. I even tried making drop box but file created by user can only be accessed by that user.

is there anyway to fix this?

any help is appricated.



Ripmax2000
Aug 29, 2013, 04:40 PM
In Server.app click on the server name on the top left, then the Storage tab on the right.

Find your share point then make sure all the users have Inheritance checked.

If the option for Inheritance isn't there for that user, then create a group, put the users in that group, and select Inheritance for the group.

Propagate permissions after this, and see if that helps.

adarkenigma
Aug 30, 2013, 12:46 AM
Thanks for reply.

well I think that worked.. now files created by SMB user can be moved by other s. but i screwed up something else.. now all read users can also create files or delete already there files on SMB share. how do I make it where they can only read files. all members are part of workgroup. should i create another group for read only users? I thought name of group should be workgroup only since its default on windows. can they still access SMB share if it give it some other name?