PDA

View Full Version : File name in Preview PDF is always "Preview of Print"




storkman14
Aug 22, 2013, 06:08 AM
This is a minor issue but it's bugging the bejezzus out of me!

I've recently bought a new iMac and MBPro both running Mountain Lion.

I use gmail as my email program. I am required for work to keep a pdf copy of emails for record keeping. So what I do in gmail (the same as I've done for years) is the following:
- click the "print" icon at the top right of the gmail email
- a new pop up "print" window then appears
- I then select "open PDF in Preview" at the bottom left
- that same email then opens in Mac Preview as a PDF
- I then try to save this PDF by selecting File/Save...
- a new pop up window appears asking me to choose my destination folder.

This is all what has been happening for a long time.

However the difference is that in the past when the final popup window appears, the file name chosen automatically by Preview used to be the the same as the Subject Line of the email, along with a "gmail" tag at the beginning. This was perfect, as it makes it very easy to identify what the email was about, and I just replaced the "gmail" tag with the date.

However now for some bizarre reason the file name automatically chosen by Preview is always "Preview of Print". But only on the iMac - the MBPro is still working fine?? Same OS, same apps, same updates.

How the heck can I get the iMac to go back to automatically choosing the email subject line as the file name (like the MBPro) instead of the non-descriptive "Preview of Print"?

I've searched for days and had no luck - please someone help me!



tag
Aug 22, 2013, 08:37 AM
Instead of choosing "Open PDF in Preview", does the title change at all if you instead choose "Save as PDF..."? Maybe directly saving it without opening in Preview first will get you back the proper filename?

storkman14
Aug 23, 2013, 06:47 AM
Instead of choosing "Open PDF in Preview", does the title change at all if you instead choose "Save as PDF..."? Maybe directly saving it without opening in Preview first will get you back the proper filename?

I have 2 things to say regarding this response.

1 - Tag, you're a legend!!

2 - This has indeed solved my issue:-)

What I've done is to still click on the print icon at the top right of the gmail screen, but it had always defaulted to my printer as the print option, hence why I then clicked on the "open PDF in Preview" link at the very bottom so I could save it as a PDF. Now I've hit the "change" button and selected "save as PDF", and now I can save it directly as a PDF and the file path name is automatically selected from the email subject line.

Voila - problem solved!

It still doesn't explain why the MBPro works fine the old way, but I'm not going to loose any more sleep over this now I've got a very good work around.

Thanks again:-)