PDA

View Full Version : Time machine restore problem




squintypanda
Aug 23, 2013, 03:59 AM
so I just tried to restore the application "league of legends" which I deleted last week. What I ended up with was a message something along the lines of "you do not have enough permission to restore the file" (sorry should have taken a screenshot), and a "corrupt or damaged file" in my current applications folder. I could not attempt to restore again since the file became crossed out in time machine and the restore option was gone. As far as I can remember I have not changed any passwords or permissions since deleting the file so not really sure what the problem was. Not really a big deal this time as I can just re-download the program off the net. But this has me rethinking using time machine as a primary backup. Did I do something wrong and should I be worried about not being able to restore important backup files in the future? Thanks in advance!!



Weaselboy
Aug 23, 2013, 09:32 AM
How did you try to restore the app? Did you do it through the Time Machine star field screen interface, or did you try and do it in the Finder. Using the Time Machine interface works better.

squintypanda
Aug 23, 2013, 11:45 AM
I entered time machine through the "Enter Time Machine" option. Went back to a random date where the application file was there, and chose to restore that file.

Weaselboy
Aug 23, 2013, 11:47 AM
I entered time machine through the "Enter Time Machine" option. Went back to a random date where the application file was there, and chose to restore that file.

Sounds like you did everything correctly. I wonder if the corruption also existed in the backed up version? Can you scroll back further in time to perhaps a better version?

squintypanda
Aug 23, 2013, 12:10 PM
When I tried restoring the file, even though it said something like "you do not have enough permission to restore (file name)", the file actually appeared in my current application folder, but it was crossed out (circle with a dash over it), and when i tried to open it it said the file was corrupt or damaged. I then went back into time machine to try and find the file again but it was gone.

The file/application was working fine before I deleted it. I mean it's not really a big deal this time, since I ended up just downloading the file off the internet again, but I'm quite worried that in the future the same problem might happen again with more important stuff. :(

Weaselboy
Aug 23, 2013, 12:13 PM
Just curious... is your account and admin account? If not, that might explain why it would not let your restore an app.

If you want to test you TM backup, you can option click the TM icon in the menu bar and select "verify backup" then just let that run.

squintypanda
Aug 23, 2013, 10:25 PM
yes it is the admin account. Only have one user/admin account and one guest account.

hrm the "verify backups" option is greyed out for me, can't click on it