PDA

View Full Version : Messages : text ok, but no audio, no video




Bruno09
Aug 30, 2013, 04:16 PM
Hi all,

I have an early-2011 MBP, running 10.8.4 and Snow Leopard 10.6.8 (dual boot).

On Snow Leopard, I use iChat with an AIM account.
This allows me to use text chat, audio and video chat, and screen sharing as well.

On Mountain Lion, I use Messages with the same AIM account.
Text chat works, but I can't use audio nor video : when I try to call a contact, or when a contact tries to call me, it displays "connecting..." but never manages to connect.

I have tried many, many things (can't list them all) as deleting .plist files, account, caches, repairing permissions, using Onyx, and even.... re-installing 10.8.4 (!!)... unsuccessfully.

Then, I tried this :

On an external hard drive, I installed a fresh 10.8.4 from my USB stick, launched Messages, added my AIM account and tried audio and video calls with a relative... it worked !

The day after, I booted again from the external hard drive and tested again : audio and video no longer worked, text was ok.
Strange indeed....
Booted from Snow Leopard : all worked.
Booted again from the external hard drive : text only.

It sounded so strange that I decided to erase the "fresh" 10.8.4 on the external hard drive, and installed it again.

Tested Messages : audio and video worked....

Rebooted the computer and tested again : audio and video no longer worked, text only.

So, here is my conclusion : audio and video in Messages work only the FIRST time I use it.
Then, it no longer works, it is text only.

Sorry for the long post and my terrible English, and thank you in advance for your help.



AlexBerkman
Sep 1, 2013, 09:12 AM
Tried FaceTime?

Thats the alternative for Lion and ML, together with messages it will give you the same; messages, audio and video to other mac or iOS users

Bruno09
Sep 1, 2013, 02:05 PM
Thank you for your response.

I often use the screen sharing ability in iChat / Messages to provide remote tech support for switchers and beginners.

Many of them still use Snow Leopard (so don't have Face Time).

I do need to be able to take control of a buddy's desktop.

I have been using iChat for years for these purposes, then used Messages.

Suddenly (I must say I do not remember when), it stopped working with Messages while keeping working with iChat (again, using the same AIM account).

Also, I need to understand why it no longer works with Mountain Lion, even on a fresh one installed on an external hard drive (in fact, it works only the first time, as explained in post #1).

Thank you for your help.

AlexBerkman
Sep 2, 2013, 06:30 AM
No I thank you...I never bothered messages before, but you made me have a go at it...but as you I do not understand why it should not work in your set up...hope you wil get it sorted :)

Bruno09
Oct 19, 2013, 12:33 PM
I finally solved my problem thanks to that thread :

https://discussions.apple.com/message/21953907#21953907

*"The basic idea is to turn off SSL in the AIM account in Messages. To do so:

1. Select your AIM account in Messages and uncheck Enable This Account.

2. Click the Server Settings tab for the AIM account and uncheck SSL.

NOTE: Doing this automatically changes the server to login.oscar.aol.com and the port to 5190.

3. Go back to the Account Information tab for the AIM account and recheck Enable This Account.

When I did this, I found that I could not immediately log into Messages because by username/password combination was no longer recognized. This seemed strange. My account had previously been xxx@aol.com (where "xxx" is my actual AIM name). To fix the problem, I removed "@aol.com" from my account name. From that point forward, everything worked beautifully."