PDA

View Full Version : No Longer Receiving iMessages on MacBook Pro




groberts1980
Aug 31, 2013, 08:02 AM
While trying to figure out why I can no longer screen share with my brother who also has a Mac (whole other issue, "Share Screen" and "Ask to Share Screen" are grayed out on both computers now) I somehow lost my ability to receive iMessages on my MacBook Pro. When I go into Messages account settings, my Google Talk and iMessage accounts are there. When I highlight my iMessage account I see my gmail address (which is my AppleID) and that is checked. Also there is my iCloud address which I don't really use for anything. I used to see my phone number which was checked, and I used to get iMessages to my Mac when my number was there.

Can anybody help me get my phone number back into the iMessage account area of Messages? I am running the latest version of everything.



gwang73
Aug 31, 2013, 09:36 AM
Disable iMessages on your phone and re-enable it again. This will register it again with Apple. Wait a minute or two after your phone is registered again and then see if your phone number appears again on the Mac iMessages. If not, try disabling iMessages on Mac now and register it again. You may need to do the same with the Face Time app if you use it.

groberts1980
Aug 31, 2013, 11:56 AM
Disable iMessages on your phone and re-enable it again. This will register it again with Apple. Wait a minute or two after your phone is registered again and then see if your phone number appears again on the Mac iMessages. If not, try disabling iMessages on Mac now and register it again. You may need to do the same with the Face Time app if you use it.

This fixed it, many thanks! I'll remember that in the future. I disabled/reenabled iMessage on my phone and the next time I launched Messages it came up with a dialog saying my phone number had been added.

gwang73
Sep 3, 2013, 08:40 PM
Great! Glad it fixed it :)

MacMan988
Sep 4, 2013, 01:22 PM
I'm also experiencing a lot of problems with iMessage. It has been always moody on my computer. Some messages are appearing in only one device, but not in the other. Some times the messages are appearing out of order etc.

groberts1980
Sep 4, 2013, 01:53 PM
I'm also experiencing a lot of problems with iMessage. It has been always moody on my computer. Some messages are appearing in only one device, but not in the other. Some times the messages are appearing out of order etc.

I also had an issue of not being able to do screen sharing, and that all came down to the conversation being in iMessage instead of Google Talk. You both have to have Google Talk accounts set up in Messages in order to screen share. Go into options, accounts in Messages and make sure your phone number is listed in the iMessages account.