PDA

View Full Version : Interesting Mountain Lion issue




willcrow
Sep 8, 2013, 05:47 PM
New here. Thanks for any help you guys can offer.

I attached a screenshot of what my UI looks like right now.

Hopefully the image is attached (I uploaded it but there's no indication of whether it went through or not). Any help is appreciated and I would love not to have to take a trip to the Apple Store.

Thanks guys.



gwang73
Sep 8, 2013, 10:08 PM
Can't see any attachment.

willcrow
Sep 9, 2013, 02:11 PM
Sorry about that. Safari has been acting up lately too. Might be why the attachment didn't show up.

I switched over to Firefox and it works now.

willcrow
Sep 9, 2013, 02:18 PM
Another screenshot:

Nermal
Sep 9, 2013, 02:22 PM
Hmm. Sometimes this could be an issue with the screen itself, but since the problem appears in the screenshots too it's not a screen problem.

Does the issue happen fairly consistently? Try booting into the recovery system (Cmd-R at the boot chime) and see whether the problem occurs there too (but don't reinstall the OS).

T'hain Esh Kelch
Sep 9, 2013, 02:28 PM
Probably a dying graphic card. What machine are you using?

gwang73
Sep 9, 2013, 02:35 PM
Have you tried a SMC and PRAM reset? This is the first thing that I would do.

After that, if the issue persists, I would look in your System Preferences—> Users & Groups, click the Login Items tab and see if there are programs there that are automatically launched when you login. I would remove items one by one and logout/login to see if it fixes it. It looks like there are programs that have menubar icons but are not starting correctly.

You can also see what is automatically starting in the following folders and remove non-essential ones.

~Users/Library/LaunchAgents/
/Library/LaunchAgents/
/Library/LaunchDaemons/

willcrow
Sep 9, 2013, 03:23 PM
Thanks a lot for the input guys.

First off, I should have pointed out that I have a "Troubleshooting Account" with default Mountain Lion settings. The issue does not persist there.

Additionally, the issue began occurring after I did a full system cleanup using Onyx (I used some options that I don't normally, which I'm convinced to a certain extent may have caused the issue). Unfortunately I haven't used Time Machine in about a month so a restore isn't an option.

T'hain -- based on the Troubleshooting Account working fine I would conclude that it's a software issue and not related to my video card. I have a MBP with Retina Display 15'' and I purchased it less than a year ago so I would hope that the Intel HD video card isn't deteriorating yet.

Nermal -- I booted into the recovery system and repaired/verified disks and performed disk permissions to no avail once I log in to my personal account. However the issue does not persist in recovery mode.

Gwang -- I did try zapping my PRAM. Is SMC another process or are they done simultaneously? I was unable to find a separate process through my Google search. I also tried removing my startup programs from Users & Groups in System Preferences one by one, unfortunately to no avail.

Do you guys think I might have to reinstall Mountain Lion? I could consider this an opportunity to try out the Mavericks Developer Preview? Or is that a bad idea? Thanks again guys. I really appreciate it.

gwang73
Sep 9, 2013, 03:53 PM
SMC reset is separate from PRAM reset. SMC is the System Management Controller and sometimes can help clear hardware glitches like graphics, audio and more.

To perform a SMC reset, go here. It's a different procedure depending on what type of computer you have: http://support.apple.com/kb/HT3964?viewlocale=en_US&locale=en_US

Thinking about this more and that you do not have this issue on the other account, this probably won't help.

Try booting into Safe Mode, login with your normal account and then restart again. Sometimes this will fix some weird issues. If this doesn't work, try deleting the com.apple.systemuiserver.plist is in your user folder ~/Library/Preferences/ com.apple.systemuiserver.plist

Then in Terminal, type: killall SystemUIServer

This will clear preferences for the menubar and rebuild it. You may need to reboot, I can't remember.

macpro2000
Sep 9, 2013, 04:37 PM
it's your graphics card.

willcrow
Sep 9, 2013, 04:41 PM
Thanks for the input but my graphics card was definitely not the issue.

Gwang -- You are a genius! Booting in Safe Mode, logging into my account and restarting did the trick. Everything is working properly now. Thanks a bunch! Have a great day and I will pay the favor forward one way or another. :)

gwang73
Sep 9, 2013, 04:51 PM
Awesome! Glad it worked!