PDA

View Full Version : Column-view: inconsistent behavior with new Finder windows




roboboticus
Sep 8, 2013, 10:30 PM
I'm struggling with some inconsistent Finder behavior regarding new windows (⌘N). I have two user accounts: one admin and one normal. I generally use Finder in column view, and I have each account set to open new Finder windows in its respective home directory (~).

I like being able to type ⌘N (open a new Finder window) followed by S to select the "Stuff" subfolder in my home directory (or DO for "Documents", M for "Movies", etc.), but I'm finding that this only works in the admin account, for some reason.

Admin account behavior:
⌘N : New Finder window opens with home directory (/Users/admin/) highlighted in blue, subfolders (Desktop, Documents, etc.) displayed in rightmost column.

S : "Stuff" subfolder (/Users/admin/Stuff/) selected (blue), columns shift to left, "Stuff" folder contents displayed in rightmost column.

Standard account behavior:
⌘N : New Finder window opens with home directory (/Users/normal/) highlighted in blue, subfolders (Desktop, Documents, etc.) displayed in rightmost column.

S : Columns remain fixed, and "Shared" (/Users/Shared/) directory is selected.


So in both accounts it opens a new window with focus on ~, while the subfolders of ~ are displayed in the rightmost column. In one account, subsequent keystrokes will select one of those subfolders, but in the other account, keystrokes will select from the folders in /Users/. I'd really like to get it to stop doing this.

Can anyone help me with this?
Thanks.



satcomer
Sep 8, 2013, 11:03 PM
Did you check System Preferences->Keyboards, Keyboard Shortcuts mini-tab?

roboboticus
Sep 9, 2013, 09:32 AM
Wow! I don't know how you knew it would have to do with that, but I checked my keyboard shortcuts prefs and remembered that in the normal user account I had changed the Full Keyboard Access option so pressing Tab would cycle through All controls. In the admin account I'd left the default so Tab would cycle through Text boxes and lists only. This setting was causing the different behavior, which kind of makes sense. Kind of :)

Anyway, I can't thank you enough. Thanks!