PDA

View Full Version : Mountain Lion cannot see any Windows PC on network




winkert
Sep 9, 2013, 02:39 PM
I manage the computers in a small office and we have a handful of Macs and a few Windows PCs (Windows 7). We use a Windows server (Home 2011) for backing up important data.

Last week two of the Macs were not longer able to connect to the shared folders on the server. As I delved deeper into this issue I discovered a few things:


Both Macs are running Mountain Lion 10.8 and were recently updated.
The ML Macs cannot ping, connect for sharing (Finder), or remote desktop into the Windows server
In fact, I can't see any Windows computer in Finder on those two Macs and I can't ping any Windows computers on the network.
The other Macs are running Lion 10.7 and have no problem seeing the Windows server in RDC, Finder, or ping.
I can ping the ML Macs from the server. The Macs aren't set up for sharing or remote desktop so I did not try that.


Because the server can see the Macs but the Macs can't see the server, I am fairly certain that this is an issue on the two Macs and the recent update. I have seen various posts online about Samba problems in ML and workgroups. I have checked and, unless something has changed, the Macs are in the right workgroup in WINS in system preferences. Not being in the same workgroup would not prevent pinging an IP though. The inability of the Macs to even ping the Windows server is the most bothersome part of this to me.

This is a very serious issue because every day these two computers can't connect to backup on the server we risk losing weeks worth of work if a harddrive fails.

Is there anything I might have missed in my diagnosis?



winkert
Sep 11, 2013, 07:51 AM
I found a solution but it has occurred to me that the network is probably not set up correctly. When I am able I may spend a day reconfiguring everything to work without this fix.

The issue:
For some reason (which I am still not sure but the network configuration probably does it), some computers end up with an IP address in 10.1.10.* range (like 10.1.10.17) rather than the 192.168.1.* range (192.168.1.53 is the server's IP). This happens to every computer using a wired connection and some computers on a wireless connection. For some reason, an update in Mountain Lion (I think) made it impossible for a computer in one IP range to communicate with the Windows server in a different IP range even though they are all on the same network and the server could see the Macs on the different IP range. It is also possible that a reset of some network device in the office mixed up the IPs.

What I did:
I manually set the IP address of the two Macs to be in the 192.168.1.* range. This worked. I was not able to change the router IP manually on ML but I was able to for Lion on a wired connection.


For some reason, Windows 7 has no problem with this network issue and can communicate with the server no matter what IP it has. I found that Lion (the older Mac OS) does have issues if it is not in the same IP range.