PDA

View Full Version : Handbrake setting?




geraldfleck
Sep 10, 2013, 10:52 AM
I am in the process of using Handbrake to rip about 90 DVDs (made from old home videos) to put them on Apple TV. But I seem to be having an issue with the size of the ripped files.

Normally, if I were to rip, say, a commercial DVD that I own, a 2-hour movie might yield (using the AppleTV 3 setting, no adjustments) a 1.25 gb file, the quality of which would be perfectly fine for viewing. The rip itself would take maybe 30-45 minutes.

When I rip my DVDs made from old home videos, each of which is 2 hours in length, the resulting file is double the size (2.5 gb), and the rip itself takes twice as long (1.5 hrs). This is puzzling, since my old home videos are hardly as "rich" (in terms of audio, video, etc.) as current blockbuster movies. So I would have thought they would be smaller...or, at the most, the same size.

Is there any way I can adjust the Handbrake settings so that my home DVDs rip more like commercial ones (that is, so they are smaller and rip faster)?

Thanks in advance for any help.



dynaflash
Sep 10, 2013, 11:01 AM
This is puzzling, since my old home videos are hardly as "rich" (in terms of audio, video, etc.) as current blockbuster movies. So I would have thought they would be smaller...or, at the most, the same size.

Not at all. the key is graininess. I am betting your old home videos are much grainier so HB need more bitrate to duplicate the grain. This results in more file size.

If the file size is unacceptable you could try the denoise filter in Picture Settings, it will remove some of the grain before it hits the encoder which will reduce the file size. Do a test though and make sure you like the visual results using denoise.

geraldfleck
Sep 10, 2013, 11:24 AM
Thanks so much for the help. I put the de-noise filter on strong and ripped just one chapter as a test. I'm perfectly happy with the quality, but the size of the file doesn't seem to have gone down at all. Any ideas?

Speaking of which: is there a way to tell Handbrake to ignore the chapter markers on the DVD when ripping? This is also in another thread, but my DVD recorder (used to transfer my old home videos to DVD) seems to have put a chapter marker on the minute, every minute...which is fine, but when I rip it in Handbrake, the video and audio "hang" for a split second at that chapter marker during playback. So my initial thought was to ignore chapter markers, but I can't see how to do this (I could de-select "create chapter markers," but that does nothing for the existing markers).

Then again, they may not be chapter markers at all, since the "Title/Angle/Chapters" pull-down menu only goes to Chapter 25. If it really were a chapter each minute, there would be 120 or so.

Any ideas? Thanks!

geraldfleck
Sep 10, 2013, 11:42 AM
It appears as though it's not new chapters but rather new "cells" that occur each minute and which trip up in the ripped video (but do not present an issue on the original DVD). Ideas?

dynaflash
Sep 10, 2013, 11:55 AM
Thanks so much for the help. I put the de-noise filter on strong and ripped just one chapter as a test. I'm perfectly happy with the quality, but the size of the file doesn't seem to have gone down at all. Any ideas?

And I presume you are comparing it with the exact same chapter and source using the same settings exactly only with denoise off ? Thats odd if so as denoise strong is usually very strong and on some sources can even give the video a "plastic" look to it.


Speaking of which: is there a way to tell Handbrake to ignore the chapter markers on the DVD when ripping? This is also in another thread, but my DVD recorder (used to transfer my old home videos to DVD) seems to have put a chapter marker on the minute, every minute...which is fine, but when I rip it in Handbrake, the video and audio "hang" for a split second at that chapter marker during playback. So my initial thought was to ignore chapter markers, but I can't see how to do this (I could de-select "create chapter markers," but that does nothing for the existing markers).

Then again, they may not be chapter markers at all, since the "Title/Angle/Chapters" pull-down menu only goes to Chapter 25. If it really were a chapter each minute, there would be 120 or so.

Any ideas? Thanks!

Sounds to me that HB is not recognizing the 1 minute chapter markers if I undertstand you correctly but hb is putting a short pause at each one minute chapter marker ? I would have to see a full activity log from the encode put on pastebin.com and then linked here to tell you exactly what is happening.

----------

It appears as though it's not new chapters but rather new "cells" that occur each minute and which trip up in the ripped video (but do not present an issue on the original DVD). Ideas?

Well, there is one thing you might try. Go to Preferences > Advanced then Uncheck "Use libdvdnav (instead of libdvdread)". Typically libdvdnav is more robust for reading dvd's however for some "home made" stuff it can get fooled (which is why libdvdread was left in as an option). Try that and see if it still get the pause every minute. No guarantees.

If it works I would do all of your old stuff then remember to switch it back for more current stuff.

Otherwise I'll need to see an activity log on pastebin.com

geraldfleck
Sep 10, 2013, 12:09 PM
Indeed, I was using the same chapter and settings. The size did go down a little when I also checked a few other picture settings (detelecine, deinterlace), and then significantly so when I reduced the constant quality from 20 to 30, but now we're obviously talking about simply reducing the quality. The quality of the originals is not all that great to begin with, so I may end up doing that since it will be hard to tell the difference.

As for the cells and the Handbrake rip inserting glitches at each minute (cell) marker, I have created a log from just one chapter (5 minutes, or 5 cells) and put it below. The rip was successful, but the resulting file has the glitches. As for what happens during playback (of the ripped file): the audio breaks and the video blocks up for maybe half a second on the minute every minute (ie, at each cell marker). When I play the DVD (in the computer, on a TV), there is no such glitch.

http://pastebin.com/feaTdxXX

UPDATE: I tried ripping the DVD first using MacTheRipper and then used Handbrake to convert to m4v...and no glitches!! So Handbrake must be doing something odd. I almost wonder if my Samsung VHS-DVD recorder put in some sort of copy protection at each cell (minute) that MacTheRipper (but not Handbrake, crucially) can remove?

Thanks again for your help. It looks like MacTheRipper and then Handbrake would be a solution, but that would essentially double the time it will take me to do all of the DVDs. So Handbrake would be ideal, if it's possible.

----------


Well, there is one thing you might try. Go to Preferences > Advanced then Uncheck "Use libdvdnav (instead of libdvdread)". Typically libdvdnav is more robust for reading dvd's however for some "home made" stuff it can get fooled (which is why libdvdread was left in as an option). Try that and see if it still get the pause every minute. No guarantees.

I think I tried this with no success when I was first fooling around with settings. I will try it again, though. Thanks. EDIT: yep, no difference. Here's the log for that one (using libdvdread):

http://pastebin.com/67xAZ54w

dynaflash
Sep 10, 2013, 01:38 PM
Indeed, I was using the same chapter and settings. The size did go down a little when I also checked a few other picture settings (detelecine, deinterlace),

...



As far as using denoise to reduce the grain and therefore file size is this paste (your first one):

http://pastebin.com/feaTdxXX

Supposed to be using denoise ?

if so:

[12:00:10] + filters
[12:00:10] + Decomb (7:2:6:9:1:80)
[12:00:10] + Framerate Shaper (2:27000000:900000)
[12:00:10] + frame rate: 30.000 fps -> peak rate limited to 30.000 fps

Indicates you were only using Decomb and not Denoise. If so this would be why denoise had no effect on it as it wasn't used.

----------

In fact neither encode uses Denoise, just Decomb (which you should leave on).

geraldfleck
Sep 10, 2013, 01:50 PM
Correct, neither of the pastes was using denoise. Both were just straight AppleTV 3 encodes (with the second having deselected "use libdvdnav").