PDA

View Full Version : USB Hub killed my two MacBook Airs




alfista
Sep 16, 2013, 12:41 PM
Hi All,

Looking for thoughts/tips/advice...

On Friday I installed a new Sabrent Arkview hub purchased from Amazon with a 4.5 star rating. 3 hours later my 2011 MacBook Air powered off dead. Brought it to the Genius Bar who confirmed it.

Over the weekend, I purchased a replacement 2011 MBA to recover my data from the proprietary SSD as my Time Machine backup hadn't run in 18 days. I go everything back up and running, and did a full backup, before connecting it back to everything this morning. I went out for a run and by the time I got back, this MBA too was dead.

I wouldn't think this would be possible from a USB but nothing else changed.

Any thoughts on what I should do or what might have been blown through the USB port that would prevent any powering up?

Thanks,

J



chabig
Sep 16, 2013, 12:45 PM
The new Air should be replaced under warranty. Other than that, I'd suggest not using that hub. It's very strange, though.

alfista
Sep 16, 2013, 01:32 PM
The new Air should be replaced under warranty. Other than that, I'd suggest not using that hub. It's very strange, though.

the replacement wasn't new - I bought it off CraigsList in order for it to be compatible with the SSD in my MacBook. The 2010/2011 has a different connector than 2012/2013.

Hub is in a forensic (i.e. zip lock) bag clearly labeled for any consumer protection options i pursue.

m98custom1212
Sep 16, 2013, 04:04 PM
What devices did you have plugged in the hub when the air died? same ones?

alfista
Sep 16, 2013, 04:52 PM
What devices did you have plugged in the hub when the air died? same ones?

Same ones/fewer, actually:

Logitech USB Audio (no power)
Apple Wired Keyboard
USB to SATA adapter connected to a DVD-ROM

I didn't have a raspberry pi powered from it, or any usb keys attached.

I wouldn't think a hub could do this, but the only other thing in common would be the apple AC adapter (in a surge protector).

m98custom1212
Sep 16, 2013, 04:55 PM
Same ones/fewer, actually:

Logitech USB Audio (no power)
Apple Wired Keyboard
USB to SATA adapter connected to a DVD-ROM

I didn't have a raspberry pi powered from it, or any usb keys attached.

I wouldn't think a hub could do this, but the only other thing in common would be the apple AC adapter (in a surge protector).

Only thing I can think of is a short in usb hub?

alfista
Sep 16, 2013, 05:03 PM
Only thing I can think of is a short in usb hub?

Any thoughts on the best way to prove that without toasting another machine? The manufacturer says that it is not possible for USB to do this.

scaredpoet
Sep 16, 2013, 10:12 PM
Any thoughts on the best way to prove that without toasting another machine?


Only way I can think of is to have Apple, or a repair shop familiar with Apple products, test the logic boards to find out where the fault is. If the USB controller is fried, then it would point to the hub.

It IS strange though... I don't think I've heard of a hub causing a total failure like this until now. I HAVE seen computers with burned out southbridges (http://en.wikipedia.org/wiki/Southbridge_(computing)) continue to function, just not well with things with USB devices.

magbarn
Sep 17, 2013, 11:11 AM
Would have using the USB port that's on a 'daughterboard' (the USB port nearest the magsafe connector is on it's own circuit board) possibly saved the logic board? I will preferentially use the USB ports on my Macbooks that are on separate IC boards that way in the future if the port wears out, it's a $50-$100 part instead of a $500 one.

TheRealDamager
Sep 17, 2013, 01:34 PM
I don't know the specific answer to your question, but will tell you that this is a pretty rare situation. I can only think of a very few blown USB ports in years of reading this board.

flynz4
Sep 17, 2013, 04:04 PM
I wouldn't think this would be possible from a USB but nothing else changed.

The SSD is also common across both machines... correct?

/Jim

luisito
Sep 17, 2013, 07:57 PM
The HUB didn't cause the problem, and can't cause a short because most HUBs are passive, meaning that they don't require AC power.

Unless... was the HUB connected to AC power?

Anyways, I am sure than I can safely conclude that your replacement was bad even before you purchased it, since it came from Craiglist, reason why people sell stuff on Craiglist, where there are no returns and policies that can protect the buyer.... and perhaps your 2011 MBA simply reached its life cycle. Some people do get back luck, one after another.

boycecodd
Sep 18, 2013, 10:50 AM
The only hubs I've ever used that were passive were those with low power requirements - old USB1.1 ones (where the max power draw was low) or the Belkin USB2 hub that can just about manage a keyboard and mouse before complaining about power, but had a DC in for those cases.

All others have needed some kind of DC power in.

A USB port can only supply so much power - when you then plug in another 4 devices into it it's not much surprise that they can overload.