PDA

View Full Version : MagSafe 2 on 2012 MBA not staying connected




HarryWarden
Sep 20, 2013, 08:35 AM
The magsafe 2 connector on my 2012 13-inch MBA becomes disconnected quite easily. Is this a function of the design so when you trip over the cord you don't pull the entire laptop off a table or wherever it may be? Sometimes when I'm lying in bed it just comes unplugged if I move around a little. Is this something I should take it to the Apple Store to have checked out? Also, if I should venture to the store, should I go today (Sept. 20) or will it be way too crowded with the iPhone launch and thus impossible to get help?



Mac.User
Sep 20, 2013, 09:01 AM
I have that issues with the new magsafe also, i think they used a weaker magnet to help prevent damage.

calvol
Sep 20, 2013, 09:28 AM
Apple should've stayed with the L-connector, much more esthetic and functional.

chabig
Sep 20, 2013, 09:52 AM
http://www.snuglet.com

Mac.User
Sep 20, 2013, 12:36 PM
I like that its probably just a small rare rare earth magnet to make the connection tighter. $20 is a lot though for that.

Mrbobb
Sep 20, 2013, 01:26 PM
I like that its probably just a small rare rare earth magnet to make the connection tighter. $20 is a lot though for that.

If it keeps annoying you all day, that's a small price to pay.

Love my Magsafe1. super low profile and works perfect. When deciding between a 2012 and a 2011, THIS seemly minor item pushed me over.

alphaod
Sep 25, 2013, 02:41 AM
Apple should've stayed with the L-connector, much more esthetic and functional.

And only be able to plug it in one way or else block the adjacent ports?

Chicane-UK
Sep 26, 2013, 12:26 PM
I have that issues with the new magsafe also, i think they used a weaker magnet to help prevent damage.

Not sure about that! The Magsafe on my 2013 Air is seriously strong.. trying to pull it out is actually quite difficult!

Spacial
Sep 26, 2013, 01:08 PM
Both my MBA and MBP have excellent mag safe connectors. I enjoy the precise fit and ideal solution to avoid damage if someone trips over the cord.

Perhaps the OP got a bad one.

3lite
Sep 26, 2013, 01:57 PM
Both my MBA and MBP have excellent mag safe connectors. I enjoy the precise fit and ideal solution to avoid damage if someone trips over the cord.

Perhaps the OP got a bad one.

Agreed. Love the magnet on these things.

calvol
Sep 26, 2013, 04:46 PM
And only be able to plug it in one way or else block the adjacent ports?

Nope, the L-shape plugs in two ways, 180degree's opposite. With the cable running to the rear, does not block ports. What I hate about Mag2 is the cable HAS to run 90deg left, which limits options on placing the Air against anything to the left (leg, desk, wall, etc). This was a step back, and one reason I'm not upgrading my 2010 Air to something less functional.

sjinsjca
Sep 26, 2013, 04:50 PM
The new MagSafes do come off easily, but there are limits. I found a microscopic bit of schmutz had gotten into my connector. Cleaned it out with a wooden toothpick, and instantly doubled the holding force.

DisplacedMic
Sep 26, 2013, 05:07 PM
Not sure about that! The Magsafe on my 2013 Air is seriously strong.. trying to pull it out is actually quite difficult!

seconded...i was actually expecting it to be weak because several people have made such a claim but mine isn't noticeably different from the magsafe 1 on my macbook. the new one is small so ostensibly it should be easier to pull out if they used the same strength magnet, but i'm not really noticing it.

The fact that some people are and others aren't might suggest a minor (albeit understandably annoying) QC issue...

jmac1642
Nov 30, 2013, 01:56 AM
just got a new mac book air, connected the magsafe for the first time and saw immediately that it was loose, jiggly, and disconnected easily.
:(
quickly googled to see if this was normal - ended up here reading sjinsjca's comment.

took a magnifying glass and looked at the port - indeed there was the smallest piece of loose (magnetic) metal in there - pushed it around with a wooden toothpick before i took a pair of tweezers and removed it and now the magsafe fits perfectly as expected.
:)
totally try checking and cleaning your magsafe port.....