PDA

View Full Version : connecting to local webserver - IOS7


loll
Sep 20, 2013, 05:17 PM
I have a local webserver on my macbook. On IOS6 I could just type in the computer name in safari and it would load.

After upgrading to IOS7, it says cant find site. I can access it from other computers in the house.

Anyone know why or how to fix this so it can connect to it?

afin
Sep 20, 2013, 05:20 PM
I have a local webserver on my macbook. On IOS6 I could just type in the computer name in safari and it would load.

After upgrading to IOS7, it says cant find site. I can access it from other computers in the house.

Anyone know why or how to fix this so it can connect to it?

Give the local IP address of the computer a try. You can find it in the network preferences. Not a fix, but a work around.

loll
Sep 20, 2013, 05:32 PM
Give the local IP address of the computer a try. You can find it in the network preferences. Not a fix, but a work around.


Thanks, that got me going in the right direction. I have it working now. It seems IOS7 requires fully qualified domain name. whereas IOS6 didnt.

So for local URLS the .local is required, seems weird to suddenly change that.

afin
Sep 20, 2013, 05:35 PM
Thanks, that got me going in the right direction. I have it working now. It seems IOS7 requires fully qualified domain name. whereas IOS6 didnt.

So for local URLS the .local is required, seems weird to suddenly change that.

Interesting, I'm sure they had their reasons. I gave up on zeroconf a long time ago and just started calling all my networked devices by IP to avoid headaches like this. Glad you found an answer. :)