PDA

View Full Version : iOS Music App no longer showing Artist pictures and has incorrect album art.


opticflare
Sep 21, 2013, 01:31 AM
Strange issue here. I did the update from iOS 6 to iOS 7, after I did the update, I noticed my synced music has just a random photo of the artist / group, that seems to be downloaded from the iTunes sites, because these pictures of the artist/group is not my album artwork.

I did a master reset on my device because I wanted to start from a clean slate, and set it up as a new phone. I went through and adjusted all of my settings and synced my music back on via iTunes, now its not showing these pictures any longer, infact, the strangest issue of them all.. is now when I view artists, the album that I synced now has a complete different album artwork picture that is not related to that album.

I am at a loss, my iTunes is extremely organized, I have everything configured to be 100% accurate for track names, artist, album, and album artwork.

Anyone have any input here? It only screwed up after the reset I did. This has to be a bug or something.

Anki
Sep 21, 2013, 03:27 AM
Strange issue here. I did the update from iOS 6 to iOS 7, after I did the update, I noticed my synced music has just a random photo of the artist / group, that seems to be downloaded from the iTunes sites, because these pictures of the artist/group is not my album artwork.

I did a master reset on my device because I wanted to start from a clean slate, and set it up as a new phone. I went through and adjusted all of my settings and synced my music back on via iTunes, now its not showing these pictures any longer, infact, the strangest issue of them all.. is now when I view artists, the album that I synced now has a complete different album artwork picture that is not related to that album.

I am at a loss, my iTunes is extremely organized, I have everything configured to be 100% accurate for track names, artist, album, and album artwork.

Anyone have any input here? It only screwed up after the reset I did. This has to be a bug or something.

I also wiped my iPhone and have issues with the artwork. I had a pdf book cover as artwork for a bunch of songs. Made no sense whatsoever.

ScottW1
Sep 24, 2013, 09:23 PM
I've been chasing this problem, too. Artwork is fine in iTunes and was always perfect on my 4S, but lots of problems when synced to the 5S.

Tried "Reset all settings, setup as new", but that didn't help.

Then I noticed that all the albums with wrong/missing artwork had some kind of punctuation in the Artist field. Like an ampersand ("&"), colon (":"), hyphen ("-"), or parenthesis ("()").

I started removing punctuation from the ARTIST field in iTunes then resynced -- and the album artwork is now correct on the 5S!. What's odd is that there are other albums that work fine even though they contain similar punctuation in the Artist field.

So something for others to try... Would like to hear others' results. I am hopeful now that it is just a simple bug with punctuation tripping up something in the transfer or artwork linkage, which should be easily fixed in a future version.

kaielement
Sep 24, 2013, 10:26 PM
I seem to have this problem on my ipad 2 running ios 7. But my ipod classic has no issues with album art strange...

Scottthescot
Sep 24, 2013, 11:17 PM
Have same issue as well will attempt to check all the punctuation
Also my shuffle playlist will not stay on every time I put phone back on in car it resets and I have to start again any suggestions