PDA

View Full Version : Can't accept "iCloudTerms and Conditions" with lates iOS 6 on ATV3




michjosi
Sep 24, 2013, 06:05 AM
Today I upgraded to latest iOS 6 on my ATV3. I did it with a complete restore. Everything seems to work, but after iTunes login I can't accept "iCloudTerms and Conditions". I click "Accept" for x times, but am always staying on the same screen.
Anybody an idea how to fix that? Thanks Michi



Niallq
Oct 21, 2013, 12:03 PM
Hi - found the same problem on new Apple TV yesterday. By default the AppleTV is set as location Cupertino and US location. The iTunes agreement is picking up the US store as the default.

Once I realised this, I changed to my local store where my iTunes account is and correct location, then retried the iCloud setup. The accept message appeared once and worked perfectly as expected. iTunes is connected and so is iCloud and my stuff streams.

It just works....:apple:

:)

michjosi
Oct 27, 2013, 04:25 AM
Thanks for the answer. Problem also solved here! Not sure what solved it because I also upgraded to Version 6.0.1, Regards Michi