PDA

View Full Version : Do not disturb is not working...help please!


fuzion11
Sep 24, 2013, 10:58 AM
I have my iPhone 5 set to iOS 7 and within the settings I have configured do not disturb to work when the phone is either locked or unlocked. I've tested this and the phone still rings when it is unlocked. Is this happening to anyone else? How do I go about fixing this? I really need/want that option to work as I don't want to receive calls first thing in the morning but would still like to be able to check my email and such without having to use airplane mode and wifi turned on.

Please advise, thank you.

Tyler23
Sep 24, 2013, 10:59 AM
I have my iPhone 5 set to iOS 7 and within the settings I have configured do not disturb to work when the phone is either locked or unlocked. I've tested this and the phone still rings when it is unlocked. Is this happening to anyone else? How do I go about fixing this? I really need/want that option to work as I don't want to receive calls first thing in the morning but would still like to be able to check my email and such without having to use airplane mode and wifi turned on.

Please advise, thank you.

Settings, Do Not Disturb, Allow Calls From - What does it say next to this? You can set it to allow calls from Everyone, No One, Favorites, or specificy a different group.

Zcott
Sep 24, 2013, 11:00 AM
Settings > Do Not Disturb > Silence: Always

fuzion11
Sep 24, 2013, 11:02 AM
I have it set to allow calls from favorites only… The caller that got through this morning was not in the favorites list though. I have it set to always on silence and it's also on a scheduled time from 10:45 PM to 9:30 AM

Tyler23
Sep 24, 2013, 11:03 AM
...

Vizio
Sep 24, 2013, 11:03 AM
Out of curiosity do you have this tab on?

I think this might be the solution to your problem.

Tyler23
Sep 24, 2013, 11:04 AM
I have it set to allow calls from favorites only… The caller that got through this morning was not in the favorites list though. I have it set to always on silence and it's also on a scheduled time from 10:45 PM to 9:30 AM

Was the caller someone you know?

C DM
Sep 24, 2013, 05:56 PM
I have it set to allow calls from favorites only… The caller that got through this morning was not in the favorites list though. I have it set to always on silence and it's also on a scheduled time from 10:45 PM to 9:30 AMDid you see a dark (non-grayed-out) moon icon in the status bar when the call came in (to make sure that DND was in fact enabled)?

moonman239
Sep 24, 2013, 06:56 PM
If the "Repeated Calls" option is set to "ON", then anyone you have not specifically blocked can reach you if they call you twice within a three-minute time interval.

fuzion11
Sep 25, 2013, 10:17 AM
Out of curiosity do you have this tab on?

I think this might be the solution to your problem.

Thanks for all the replies everyone…

Just to be clear yes I understand the settings well and had them all enabled so as to assume that no call would be able to make it through my phone whether the phone is locked or not. I did know the caller, but he is not in my favorites list. Nor do I have the option of allowing someone to breakthrough do not disturb if they call twice within a couple of minutes. I have my options set to always and not only when the phone is locked. I did not have it set to manual as I have a schedule set up. It's set to go on at 10:45 PM and off at 9:15 AM… This caller called at around 8:45 AM, while the phone was unlocked.

I wish I had a landline or an extra cell phone to try this out more, but unfortunately that's not the case. Can anyone else test this and report their findings?

Tyler23
Sep 25, 2013, 10:23 AM
Thanks for all the replies everyone…

Just to be clear yes I understand the settings well and had them all enabled so as to assume that no call would be able to make it through my phone whether the phone is locked or not. I did know the caller, but he is not in my favorites list. Nor do I have the option of allowing someone to breakthrough do not disturb if they call twice within a couple of minutes. I have my options set to always and not only when the phone is locked. I did not have it set to manual as I have a schedule set up. It's set to go on at 10:45 PM and off at 9:15 AM… This caller called at around 8:45 AM, while the phone was unlocked.

I wish I had a landline or an extra cell phone to try this out more, but unfortunately that's not the case. Can anyone else test this and report their findings?

So repeated calls is set to off?

I have never experienced what you are experiencing. It always works for me exactly as it is set.

fuzion11
Sep 25, 2013, 10:24 AM
So repeated calls is set to off?

I have never experienced what you are experiencing. It always works for me exactly as it is set.

Yes repeated calls is set to off… I have it set up tighter than Fort Knox, that's why I can't understand how that called that through? lol

fuzion11
Sep 25, 2013, 10:52 AM
It just happened again… I had do not disturb set to manual and a phone call just got through while I was using Safari. This pisses me off beyond belief! Is this not happening to anyone else? Does anybody have any more suggestions for me… But restore is out of the question as I don't have a computer to restore from backup from.

Tyler23
Sep 25, 2013, 10:53 AM
It just happened again… I had do not disturb set to manual and a phone call just got through while I was using Safari. This pisses me off beyond belief! Is this not happening to anyone else? Does anybody have any more suggestions for me… But restore is out of the question as I don't have a computer to restore from backup from.

Can you take a screenshot of your Do Not Disturb settings page? You may need two screenshots to capture everything - then post here.

Not trying to insult you - just saying, it never hurts to have a second pair of eyes look over the settings.

Also, if it comes to it, you can just back up to iCloud, Restore All Settings, then restore from your iCloud backup.

fuzion11
Sep 25, 2013, 11:03 AM
Can you take a screenshot of your Do Not Disturb settings page? You may need two screenshots to capture everything - then post here.

Not trying to insult you - just saying, it never hurts to have a second pair of eyes look over the settings.

Also, if it comes to it, you can just back up to iCloud, Restore All Settings, then restore from your iCloud backup.

I would gladly take a screenshot for you… But will I be able to upload that image from my iPhone as I don't have access to a PC at the moment?

fuzion11
Sep 25, 2013, 11:06 AM
Here is the other pic. Thanks for your help.

Tyler23
Sep 25, 2013, 11:09 AM
I would gladly take a screenshot for you… But will I be able to upload that image from my iPhone as I don't have access to a PC at the moment?

Ok - just wanted to confirm. I'm guessing you have it set to Manual at the moment?

If I were you, at this point I would go to General--Reset--Reset All Settings. This won't delete anything from your device, it will just restore all settings to their defaults. You'll need to go through and change your wallpaper, Ring/text tones, Privacy settings, etc.. But it's better than a full restore and may fix this issue.

Worth a shot.

C DM
Sep 25, 2013, 02:21 PM
I would gladly take a screenshot for you… But will I be able to upload that image from my iPhone as I don't have access to a PC at the moment?Just tried it with the exact same settings and made a call from a landline and it went right to voicemail after two rings. And the phone didn't show anything (except for a missed call badge on the phone app that appeared when I unlocked it and missed call information in notification center when I checked it).

fuzion11
Sep 26, 2013, 10:08 AM
Thanks guys for all the help. I'll try to run some tests of my own once I have a landline in front of me and if they all fail ill then have to reset my phone from within the settings.

fuzion11
Sep 28, 2013, 09:59 AM
From what I've read this is a widespread problem, being on different carriers, different countries and different devices. One thing in common is everyone is saying this is happening after up grading to iOS 7.0

Anyhow, here is a link to the apple.com support site… Check it out for yourself if you're in the same boat as myself.

https://discussions.apple.com/thread/5356737?start=30&tstart=0

fuzion11
Sep 29, 2013, 07:33 AM
I wrote to Apple and explained the issue. All I can do is hope they fix this in iOS 7.0.3

Gypsy36
Sep 29, 2013, 08:38 AM
I have the same issue - do not disturb randomly allows calls through. Also What'sapp isn't silenced so it isn't worth it for me.

fuzion11
Sep 30, 2013, 09:19 AM
On my side of things...ALL my calls come through. What's weird is text or email alerts don't make a sound. They all come through, just without a sound...the way it should be. Once I figure out how to fix this issue or once Apple fixes it via an update I will be one happy guy!

Tyler23
Sep 30, 2013, 09:28 AM
On my side of things...ALL my calls come through. What's weird is text or email alerts don't make a sound. They all come through, just without a sound...the way it should be. Once I figure out how to fix this issue or once Apple fixes it via an update I will be one happy guy!

Have you tried to Reset all Network Settings? Or a full restore?

fuzion11
Sep 30, 2013, 09:47 AM
Have you tried to Reset all Network Settings? Or a full restore?

I've tried reset all settings and reset network settings, all with no change. I can't do a fresh restore unfortunately because I'd lose too much of my stuff as I don't have the PC I kept all this iPhone stuff on.

Tyler23
Sep 30, 2013, 09:54 AM
I've tried reset all settings and reset network settings, all with no change. I can't do a fresh restore unfortunately because I'd lose too much of my stuff as I don't have the PC I kept all this iPhone stuff on.

iCloud backup? And don't suppose you have iTunes Match..?

That is a strange problem. Do Not Disturb works perfectly for me (iPhone 5) and my fiancee (iPhone 4S). Wonder what the cause is.

fuzion11
Sep 30, 2013, 10:00 AM
iCloud backup? And don't suppose you have iTunes Match..?

That is a strange problem. Do Not Disturb works perfectly for me (iPhone 5) and my fiancee (iPhone 4S). Wonder what the cause is.

I do have iCloud for backup but unfortunately not iTunes match… So I will lose all my music and videos. If I were to restore from an iTunes backup would all my game data still be intact? For example if I'm on level 21 on Angry Birds, will I still be on level 21 after the restore or will it reset back to the first board?

Tyler23
Sep 30, 2013, 10:07 AM
I do have iCloud for backup but unfortunately not iTunes match… So I will lose all my music and videos. If I were to restore from an iTunes backup would all my game data still be intact? For example if I'm on level 21 on Angry Birds, will I still be on level 21 after the restore or will it reset back to the first board?

iTunes and iCloud backups both backup app data, so your game data should be saved. Never had an issue with it myself, at least.

Kaussy
Sep 30, 2013, 08:06 PM
I have this same issue with my Do Not Disturb. All my settings are correct but its still allowing calls through!! Very Frustrating. Im on a iphone 5 running 7.0.2 My iPhone 5s should be here tomorrow or the next day then I shouldn't have this problem anymore. I feel for the OP its very frustrating having a feature that just plain isn't working. And it worked fine on iOS 6.

fuzion11
Oct 1, 2013, 10:06 AM
I have this same issue with my Do Not Disturb. All my settings are correct but its still allowing calls through!! Very Frustrating. Im on a iphone 5 running 7.0.2 My iPhone 5s should be here tomorrow or the next day then I shouldn't have this problem anymore. I feel for the OP its very frustrating having a feature that just plain isn't working. And it worked fine on iOS 6.

Something odd happened this morning… My sister who also owns an iPhone called me within the hours I have scheduled for do not disturb and the call went directly to voicemail as it should. But someone else who called from a landline a couple minutes later, say 10 minutes later…the call came right through. Basically what I'm saying is, until Apple fixes this bug I think do not disturb will only work when calls are being placed from iPhone to iPhone and will not include other cell phones or landline's

What do you think?

fuzion11
Oct 4, 2013, 08:09 AM
From what I understand iOS 7 .0 .3 is only going to contain fixes for the lock screen bug but we can hope it includes something for do not disturb.

fuzion11
Oct 24, 2013, 09:28 AM
I was hoping after updating to 7.0.3 DND would hopefully be fixed… Unfortunately it doesn't seem the case as it is still broken.

How do we get Apple to understand that it is an iOS issue?

Tyler23
Oct 24, 2013, 09:36 AM
I was hoping after updating to 7.0.3 DND would hopefully be fixed… Unfortunately it doesn't seem the case as it is still broken.

How do we get Apple to understand that it is an iOS issue?

Have you restored your phone yet?

I know it's frustrating, but I really think it's a localized issue. There seem to be very few reported cases of others experiencing this - and I think a restore will be the way for you to get it solved.

fuzion11
Oct 25, 2013, 11:46 AM
Have you restored your phone yet?

I know it's frustrating, but I really think it's a localized issue. There seem to be very few reported cases of others experiencing this - and I think a restore will be the way for you to get it solved.

Hey Tyler,

Yes I have restored from new just recently and it didn't help at all.

Any other ideas?

Tyler23
Oct 25, 2013, 11:48 AM
Hey Tyler,

Yes I have restored from new just recently and it didn't help at all.

Any other ideas?

Just to clarify (not to doubt you), you connected to your computer, and in iTunes, hit restore? And you did not restore from a back up?

fuzion11
Oct 26, 2013, 11:40 AM
Just to clarify (not to doubt you), you connected to your computer, and in iTunes, hit restore? And you did not restore from a back up?

Yes, totally set up from new...and no help either.

PeteLP
Dec 18, 2013, 07:48 AM
Did you ever get resolution? If not, I'd suggest trying two more things

1- change your DND settings to allow calls from "no one"
Test this in a variety of circumstances, with several numbers. If this works properly, then the problem is more isolated, and some of us can test the same "allow calls from: MyGroup" feature

2- if your phone worked properly when allowing calls from "no one", then the next thing to try is to completely delete the group tag "mi familia" then recreate it and add the people to it again. There might be something corrupted in the current mi familia data which could be triggering this bug. Since you'll do the group changes on your computer, you want to confirm that the group is seen as missing from the iphone before you re-add the group. Just to make sure that the deletion and re-adds properly came across from iCloud

Stuke00
Dec 18, 2013, 08:39 AM
Yes, totally set up from new...and no help either.

I remember reading somewhere that people were having issues with this for carriers that have a caller ID enabled. Like on Verizon, I can have it send the caller ID name across with the number. If that is on, do not disturb does not work. If it is off, it works just fine.