PDA

View Full Version : PB G4 1.33ghz Slot-Loading Combo Drive Acting Up...




CoyoteJack
Jan 2, 2006, 01:13 PM
Hi there, just posting about a 1.33ghz aluminium PowerBook with a slot-loading Combo Drive which has recently been acting up. The drive is stubborn in accepting media (CDs and DVDs of all brands), and you need to force the media in, and when ejecting the drive only spits out the very tip of the CD before swallowing it again. Not only that, but it's stubborn in letting go of the CD and I have to grab the tip and yank it out. It feels like the drive is 'tight', if that makes any sense, and I have to push it past some kind of blockage on what I think is the side nearest the back of the PowerBook. I might add that pulling out the CD produces a set of short parallel scratches on the right of the CD (that is, the edge of the CD closest to the opening when ejected). This has just started recently, and previously the 'Book and Drive worked like a charm. In fact, the Drive still does, it just doesn't want to accept the CDs. Once the bloody things are in, the Drive reads perfectly. Any suggestions? I have a PBFixIt take-apart guide, but I'd really rather not take it apart if at all possible.

Unfortunately, the 'Book is out of AppleCare warranty. :( Any help would be muchly appreciated. I'd love to be able to look into the thing, but I can't see past the dust ruffle.

EDITED: Accidentally hit TAB instead of CAPSLOCK and then hit space, saving the post with only the capital letters H and I in the post. :P



CoyoteJack
Jan 5, 2006, 04:58 PM
Nothing, friends? I'm really, truly hoping someone out there can help me with this problem. Also, I'd like to clarify, my mistake, it's a 1ghz PB Aluminum, not a 1.33.

Cheers in advance!