PDA

View Full Version : Canon SD500 not mounting




VAmin
Jan 4, 2006, 12:18 PM
Google has not provided me with the solution, so perhaps you guys can:

I have always been able to use iPhoto to get images off the camera before, but now when I connect the camera and turn it on, it won't show up. The odd thing is that iPhoto still opens automatically upon connection. I've tried to get to the camera through Image Capture, but it does not show up there either.

I know I can just buy a card reader, but I'd rather solve the problem rather than just avoid it.

Thanks in advance,
Victor



iMeowbot
Jan 4, 2006, 12:41 PM
It uses a standard mini USB cable. Would you happen to have another hiding in a drawer somewhere that you could try?

VAmin
Jan 4, 2006, 12:44 PM
Sorry, no other cable. One other thing I remember: the last camera I hooked up was a Nikon 5900. Usually, the SD500 is the only camera that I attach to the computer, but over Christmas break I uploaded some pictures from my mother's camera. This is the first time since then that I have tried to upload pictures. Related?

iMeowbot
Jan 4, 2006, 12:49 PM
Could be. It wouldn't hurt to ferret around in your Library/Preferences, trash anything starting with com.apple.ImageCapture (there may be several, hiding in subfolders), log out and start over. If you're on Tiger, the Spotlight search in Finder will aid your hunting.

simie
Jan 4, 2006, 12:51 PM
Most camera's place an icon on the desktop - try opening up the camera's icon and view or copy the files from the memory card that way.

It may be that once you have got your photo's off of the memory card, that the card needs formatting.

I have had this problem before now. I connected my camera to a pc which read the card first time. After all the pictures were copied off, I simply formatted the card using the camera, iphoto then was able read the card again, I took a few shots just to test it. I transferred the pictures off the PC through my LAN.

If you don't have a card reader, then I would suggest getting one, in my case a card reader would not even read the compact flash card.

VAmin
Jan 4, 2006, 01:11 PM
I tried deleteing both the Image Capture and iPhoto files to no effect. Also, the camera has never mounted to the desktop, so I can't just drag and drop.

EDIT: I meant the plist files

VAmin
Jan 4, 2006, 05:58 PM
I think the problem goes deeper than just camera-to-computer. I just tried to print something through a USB printer and that doesn't work. Reinstalling doesn't work now either. It seems that the USB ports are fine, though, because my shuffle still mounts.

VAmin
Jan 4, 2006, 06:53 PM
OK, I actually fixed the problems. Surprisingly enough, repairing disk permissions solved everything (that's a first). Thanks a lot for your help you guys.