PDA

View Full Version : iBook Running Slow- disc utility says I have 'no valid packages'




Griffindor73
Jan 7, 2006, 07:19 AM
Help!
My 12'' iBook (1.2 G4 60gb version) has been running a bit slow of late, so I went to repair permissions, but the Disc Utility program refuses to do it, telling me I have 'no valid packages'?

Does this mean there is something physically wrong with the hard drive, or would now be a good time to think about doing a reinstall of the whole machine- the hard drive is rather full on it?

Any ideas?



Applespider
Jan 7, 2006, 07:38 AM
How full is your hard drive? If it's got less than about 6GB free, then it's going to be slow since there isn't enough room for OS X to manage its virtual memory as effectively.

As for not having valid packages, did you start cleaning stuff out to make some more space and perhaps delete the things in the Library/Receipts folder? That's what allows you to Repair Permissions. If you've trashed them, you won't be able to repair again until you reinstall the software or find someone running the same set-up and copying over theirs.

If you need more space, then try running Delocalizer to get rid of language preferences, getting rid of some of the printer drivers, losing Garageband/iDVD along with their themes/loops in Application Support if you don't use them and that should get you about 6GB back. Or burn some files you don't use often to CD/DVD and archive them off.

Griffindor73
Jan 9, 2006, 11:47 AM
I have got less than 6GB left- thats easily solved, I'll just transfer it over to my iMac,
I was just worried that the hard drive might be faulty- I think I might even kill two birds with one stone and do a totally fresh re-install.

Thanks! :)