PDA

View Full Version : XCode - unable to add .h files




blairmcintosh
Feb 1, 2006, 07:24 AM
Greetings,
I made a static library and various tests programs, obj C and Xcode. Now I am writing a command line tool that uses that library. All running smoothly for a while but now when I attempt to add one of the .h files I cannot select it. It is dimmed. I have added most of them but this one just evades me. I thought that perhaps I didn't "add" the file when I created the library so deleted both it and its corresponging source file and "added" them again. Same result. Any suggestions greatly appreciated.



robbieduncan
Feb 1, 2006, 07:41 AM
I've seen this before. I assume it's an XCode bug. Find the file in the Finder and drag it to where you want it on the file tree in XCode. This will trigger the normal Add options.

blairmcintosh
Feb 1, 2006, 08:01 AM
My God. How much time have I wasted on this? mmmmmm about 12 hours. Well Thanks heaps. I got in in there. Three hours writing code and and 12 doing nothing. I first tried to drop it into the source leaf but it wouldn't have that so I put it into the project root and, as you said, it opened the "add ....." dialog.

robbieduncan
Feb 1, 2006, 08:27 AM
I've also found in the past that quiting XCode entirely and then reopening it and the project sometimes clears this.