PDA

View Full Version : .cpgz file just keeps going in a circle - help!




annk
Feb 5, 2006, 12:54 PM
I was mailed a .sitx package with a font-testing app (Im having trouble getting certain fonts going in order to use a Norwegian-Chinese dictionary on my PB, and one of the people involved in the project mailed me the .sitx and asked me to check out the fonts and mail him a screenshot).

I unstuff, then get a new icon on my desktop, called FontTest.sitx.cpgz. The icon is a white sheet of paper with a zipper.

When I then double-click on this new icon, it just unarchives to give me a new sitx - a sort of version II of the original file, this time called FontTest 2.sitx.

This goes on and on - I never get to the app Im supposed to use to test out the font problem.

Any idea what Im doing wrong? I found a couple references to the same sort of problem with .cpgz-files in a quick Google search, but without any suggestions for solutions.



Eniregnat
Feb 6, 2006, 01:49 PM
CPGZ = gzipped archive
I thought that these were created from the ditto command? Basically a zipped archive.

OSX should natively be unable to unzip the archive. Try
Stuffit Expander (http://www.stuffit.com/mac/expander/) for expansion of the SITX componet. SITX, is basically a more compressed version of the SIT format, that allows for long UNIX naming, and allows for 512 bit encryption of the archive.


If the archive is malformed, it won't unzip correctly.

annk
Feb 6, 2006, 01:52 PM
Earlier today I finally ended up managing to get at the app in the package by using Stuffit Expander to open the .cpgz file. Using Stuffit on the sitx-file only created .cpgz.

xroox
Feb 2, 2010, 04:53 PM
Having the same problem, stuffit expander opens the .cpgz but not the resulting .zip file. When I try and open the .zip file that stuffit has created it just creates another .zip file.

Weird stuff!

John Doe 57
Feb 2, 2010, 06:10 PM
Having the same problem, stuffit expander opens the .cpgz but not the resulting .zip file. When I try and open the .zip file that stuffit has created it just creates another .zip file.

Weird stuff!

Wow! This thread will celebrate it's 4th birthday in a few days.

Every time I run into this problem, I rename the ending of the file to RAR or SIT. Normally it works, other times it doesn't.

wrldwzrd89
Feb 3, 2010, 07:22 AM
I've had this odd problem before, actually. It's easy to fix - starting with the original archive (not the CPGZ Archive Utility creates when it tries to extract it), use The Unarchiver to open it. It's a lot more capable, and is usually able to figure out how to unpack it.

data2insight
Apr 6, 2010, 02:10 PM
Thanks for this post! I was having the running in circle problem with a cpgz file too. I read the thread and downloaded the UnArchiver and it opened the gunzipped archive beautifully. What a time saver. I will make a donation to folks who make the UnArchiver for sure!

mooncaine
Jul 30, 2010, 02:59 PM
I'm working with Google Earth's KMZ files, which should simply unzip to a text file with extension .KML ....

Mac OSX just makes a file with .cpgz extension, which it will in turn unzip into another .zip file, etc, ad infinitum.

:mad:

kharisma
Nov 6, 2010, 05:23 PM
I've been trying The Unarchiver, Archive Utility, Stuffit, FileJuicer on both the original zip and the resulting .zip.cpgz file, plus on the .gz file that FileJuicer produces.

FileJuicer does *not* "unpack all the files" as their ad suggests :(

Stubbornly refuses to open.

I think I found a solution once before, but that was when I knew the result should be a pdf, so changed the extension.

Did find one web page that says .cpgz files are actually created on a Mac so may pose a problem for Windows users! We Mac users seem to be similarly challenged!

Any other suggestions?

marvh
Nov 18, 2010, 12:44 AM
I had the same problem, .zip extracting into.cpgz. Even using Stuffit Expander by double clicking the file it still kept going in circles. However, MOST of these files extracted just fine by right-clicking on the original .zip file and selecting Stuffit Expander under the "Open With" option.

kevin86
Apr 20, 2011, 07:22 AM
Just wanted to say thanks to everyone in this thread. I was having the same problem. Read this thread and then downloaded the unarchiver from the mac app store (for free!!!!) and it worked perfectly.

Thanks so much!!

Carlene
May 30, 2011, 08:39 PM
Wow, thanks! I thought I was losing it... couldn't figure out why it wasn't working. :)

jswan1963
Dec 11, 2011, 08:05 PM
I tried all of the recommended fixes and still couldn't get the cpgz file to open. Any more thoughts on this?

LaVerdana
Jan 5, 2012, 04:24 AM
I started with an ePub file and changed the extension to zip, but Snow Leopard still wanted to use Adobe Digital Editions with it after the first try, where it had created a .cpgz file with it! So I tried opening with StuffIt Expander 11.0.2, (that's just the one I had - I RARELY use it, because normally Mac OS X handles zip files nicely). The main gotcha there was that it quickly expanded the zip into a folder nowhere to be seen! Then I had to firstly open StuffIt and check the preferences to find where it was set to save files! I could then go and move the expanded folder back to where I wanted it and also changed the preferences to put expanded files in a folder where the original zip file was. :)

Wicky
Feb 14, 2012, 01:46 PM
On & off, I've been having the same infuriating problem for ages... zip becomes zip.cpgz, becomes zip2.cpgz, etc., ad infinitum. None of the solutions explained here (or elsewhere) have worked.

None of the Zip/Archive apps work, no amount of file suffix renaming makes a difference. Eureka moment... "it's the files"!

The problem is infrequent, but I have had it a few times and always with zip files. Thinking back, the common ground is files that have been stored or distributed via AmazonS3 and downloaded via Firefox. There's some compatibility issue. Maybe it's a plugin... who knows?

I set Chrome up as my primary browser, rebooted & downloaded the files again. Problem solved... at least for me!

cocolino
Feb 28, 2012, 02:46 AM
Hi, I have just encountered this problem with a .zip file and have tried all the solutions found on the net, but it seems that some error occurred when I downloaded the file and that caused this cpgz/zip cycle. I just downloaded the file again (same browser) and this time I could unzip it right. Just check the size of the file, if it is very small (mine was 28bytes), it was probably not downloaded right. When I downloaded it the second time, the file was 1Mb. I hope this helps at least some of you :)

ScottDunn
Apr 4, 2012, 12:04 PM
It is certainly not a fix, however I have experienced this in the past and sometimes simply re-downloading works. Downloading the file using a different browser always seem to work. I normally use Firefox and then use Chrome when I have the problem.

whateveruloveur
Apr 26, 2012, 12:41 AM
wow, thanks. i just googled this... not even expecting to find any results, then read this and downloaded the Unarchiver. it worked immediately, no problem.

Sirolway
Apr 30, 2012, 07:26 AM
wow, thanks. i just googled this... not even expecting to find any results, then read this and downloaded the Unarchiver. it worked immediately, no problem.

+1
Fantastic news - recovered a bunch of corrupted zip files that I thought were toast.
Off to donate to The Unarchiver now ...

jahinton3
Jul 14, 2012, 06:31 AM
I had the same problem and after reading some replies in this forum I tried Stuff It Expander. It didn't work. Read some more and tried UnArchiver. Worked easily. Note this isn't someone who works for Unarchiver... just a new Mac user!

:)

camslice
Oct 7, 2012, 04:53 AM
Your unzipping software may produce a .cpzg from a .zip file if the .zip file hasn't finished downloading. Check your browsers to see if the .zip file you're trying to unzip has finished downloading completely.

Daniieel
Jan 10, 2013, 05:59 AM
This worked for me.

Instead of just downloading the file from WeTransfer
I named it xx.zip, I put the .zip behind the file.

Hope this helps!

Xenophyte
Mar 28, 2013, 03:49 PM
renaming the .ZIP to .SIT (then double-click) worked, thanks!

talonaspica
Apr 1, 2013, 01:43 AM
renaming the .ZIP to .SIT (then double-click) worked, thanks!



This works for me. Thanks :)

eggsaladjunkie
Jul 16, 2013, 05:53 PM
I HAVE A SOLUTION:-
The problem is NOT with the file itself but with Stuffit Expander, and the version you are using to unstuffit.

The way to open your .ZIP, .RAR files, is to re-install an older version of Stuffit.

I have 15.0 installed at the moment. I re-installed 10.0.2 it still didn't open, I then re-installed 8.0.2 and it worked. Job done.

Obviously some files had been compressed using the older version.

I downloaded the older Stuffit from:-
http://www.stuffit.com/mac-stuffit-download.html

Hope it works for you.

OK, I did that. Now when I use the Stuffit Expander I get a FOLDER named "slsx folder". Inside the folder among other folders, is a document called [Content_Types].xml. This is identified in "Get Info" as an "Omni Outliner" document that naturally won't open.

What's the SIMPLE solution to this, other than just throwing away the computer, which is most tempting.

It is only the most basic function in the world for a networked computer to be able to download and open attachments!

WHAT IS UP WITH THIS? It smells like someone is trying to sell something.