PDA

View Full Version : I can't empty the Trash!


Beej
Jan 31, 2002, 07:29 PM
Help!

I can't empty the Trash in OS X 10.1.2

I've been trashing SO X backups from a second HD. When I try to empty it, I'm told:

"The operation cannot be completed because you do not have sufficient privileges for some of the items."

I've gone to each folder in the Trash and copied R+W permissions to everything, but it still won't work.

I've logged in as root and tried to ls my .Trash folder, but it says there's nothing in there...

Any ideas?

And before PC lovers decide to use this as another reason to bag the Mac OS, I admit this is a problem, and I don't need you to tell me. I'm trying to fix this problem, if I wanted to start a Mac OS bag-session, I'd do it elsewhere - just as you should.

Sorry about that... :)

Ensign Paris
Jan 31, 2002, 07:43 PM
Try:

a) Boot from a OS9 CD and Empty Trash
b) Search for a program on version tracker called oblitorator or something like that!

GeeYouEye
Jan 31, 2002, 07:55 PM
Boot into OS 9, use FileTyper to make the .Trash visible, then throw that away, create a new one, and have FileTyper make it invisible. Reboot into OS X

Beej
Jan 31, 2002, 08:25 PM
Sweet. Thanks guys!

Beej
Jan 31, 2002, 09:01 PM
I just did it. The FileTyper method worked like a charm. Thanks again! :D

Taft
Jan 31, 2002, 09:14 PM
If you like using the command line, just 'ls' to the .Trashes directory. There are usually sub-folders in .Trashes which correspond to different users. If there is only one user its generally 501. Then just 'sudo rm' the files you want to delete. Like this:

>cd /.Trashes
>ls -aF
501/
502/

>cd 501
>ls -alF
drwx------ root wheel 0 Jan 26 00:21 untrashable/

>sudo rm -rf untrashable

Careful with the 'rm -rf', it can be potentially dangerous!!

Hope this helps!!!

Beej
Jan 31, 2002, 10:23 PM
Originally posted by mrtrumbe
If you like using the command line, just 'ls' to the .Trashes directory.
I think you might mean cd, not ls... :D

Thanks for the tip. I tried using the command line (like I said above) but I was looking in the .Trash folder in my home dir, not the .Trashes dir elsewhere as I should have been. Oh well, I know for next time.

MacAztec
Jan 31, 2002, 10:45 PM
Whenever I get that error, I force quit the finder. Try that and then try emptying again.