PDA

View Full Version : iBook hard drive won't mount, failed!




cosmic
Mar 7, 2006, 05:38 AM
Hello everyone

My iBook's hard drive failed yesterday, it won't boot normally. What I get is a flashing question mark. The night before, the hard drive suddenly started clicking alot and then the system crashed.

I have tried a few options to get to the drive, but the drive will not mount. Tried resetting the PRAM, booting up from a repair CD, using the 'x' key, and connecting the iBook by firewire as an external drive. It won't mount.

Does someone have any experience with this? Is using recovery software going to toast it even more? Is my only resort to send the drive to a restore service place? I'd like to get some files I didn't get the chance to backup, this happened so fast. :(



mad jew
Mar 7, 2006, 07:05 AM
I reckon Target Disk mode (the Firewire part) was probably your best bet. Since it didn't work, I'd stop trying for fear of doing any damage (if possible) and taking it to a professional.

Just out of interest, can you boot off the CD at all? If so, then it's sounding like a classic failed hard drive which is good in that they're easily replaced. :)

cosmic
Mar 7, 2006, 08:45 PM
I can boot off a CD, HD is nowhere though. Thanks, I will try some professional help. Just hoped there was a last try!

frankblundt
Mar 7, 2006, 08:50 PM
There's Disk Warrior (http://www.alsoft.com/DiskWarrior/) but it don't come cheap.