PDA

View Full Version : Windows is wierd --can't delete?




whyrichard
Mar 27, 2006, 03:11 AM
Hello,



this is not necessarily correctly posted because this problem isn't on my macbook, it's on my workstation.



what does it mean when i cannot delete a file?

it says "cannot delete: the directory is not empty"


that makes no sense to me whatsoever.


r.



mad jew
Mar 27, 2006, 03:13 AM
What exactly are you trying to delete? :)

whyrichard
Mar 27, 2006, 03:15 AM
a folder full of files. many different file types. mostly simple ones however. text and a few photos, pdf's.



whats up?


r.

mad jew
Mar 27, 2006, 03:22 AM
Okay, but what's its location? I'm not sure how helpful I can be, but this sort of information may help all the same.

FWIW, if I'm struggling to delete something in either Windows or OSX, I drag it to the Trash (or Recycle Bin), restart and then try emptying it. Of course, this is only relevant if it's the emptying stage that's causing grief. :)

whyrichard
Mar 27, 2006, 04:02 AM
i try to select objects in a folder on my desktop, i right click and go to delete, that is when i get the error message.


r.



SPECIFICALLY, presently, it is an itunes library i am trying to backup onto my external hd.

i think the problem is with the file names? originally, more of these songs were on my mac. then i moved them to my pc, and now i want to back them up onto my external.


what other methods, besides all the obvious ones, are there for me to move my library onto my external hd? i actually want to use my external hd as my primary library, just not have it on my desktop's internal hd. it's getting to big!



r.

mad jew
Mar 27, 2006, 04:56 AM
Can you drag it to the Desktop? Is iTunes closed while you do this? :)

Sorry for not being very helpful. If it was a Mac I'd kinda know what to do. :o

DeeJay Dan
Mar 27, 2006, 05:09 AM
Rich,

Open the folder that you're trying to delete, go to tools > click folder options in the view tab select show hidden files and folders. Then look in the folder anything that's greyed out (dim looking) is a hidden file/folder. Try deleting everything but the hiddens ones. After that manually right click on each hidden file and make sure it isn't set to read only.

Other than that..Just try drag and drop the files on the external. When I'm moving stuff to an external off my HD I select the files press ctrl X (cut) open my external drive and ctrl V (paste) [EDITED]

I don't think it's a file name problem, XP (I presume you're running) is pretty tolerant. The only thing it gets pissed about is slashs.

Hope it helps,

Dan

mad jew
Mar 27, 2006, 05:16 AM
When I'm moving stuff to an external off my HD I select the files press ctrl X (cut) open my external drive and ctrl C (copy)


Good advice that, but I think you mean CONTROL-V for paste. :)


I don't think it's a file name problem, XP (I presume you're running) is pretty tolerant. The only thing it gets pissed about is slashs.


It's not so much XP but rather the format of the drive. NTFS should be fine but FAT32 can be picky. :(

DeeJay Dan
Mar 27, 2006, 05:33 AM
Good advice that, but I think you mean CONTROL-V for paste. :)

Yeah you got me, I was actually copy/pasting on another machine as I was typing, so my brainwaves got crossed. I fixed the original post.

It's not so much XP but rather the format of the drive. NTFS should be fine but FAT32 can be picky. :(

Good point, I missed that. Default install for XP is NTFS though.