PDA

View Full Version : My PowerBook is not recognizing its Airport card. Help!




QueenGoblin
Apr 8, 2006, 05:51 PM
My Powerbook took a short drop, and landed flat on its bottom. It said it needed to be restarted and ever since it no longer thinks it has an Airport Card. The Airport icon is no longer on the top toolbar and if I go into the System it tells me I do not have a wireless card at all. I took the battery out and removed the card. I don't see an obvious problem, but then I don't know what I am looking for. Can anyone tell me a way to determine if the problem is with the card itself, or with the computer's ability to read the card? I would just buy a new card, but I am afraid I will put the new one in and my mac won't realize it is there either. Friend's/family are all PC users so I can't try swapping the card out on someone esles machine...Help!



Eniregnat
Apr 8, 2006, 06:10 PM
Is the card actualy seated correctly?

iFixIt.com (http://www.ifixit.com/Guide/) guides.

Post your model and it might help people trouble shoot for you.

QueenGoblin
Apr 8, 2006, 06:23 PM
It's a 12 inch G4 1.33 GHz running OS X version 10.3.9

me_94501
Apr 8, 2006, 06:49 PM
My Powerbook took a short drop, and landed flat on its bottom. It said it needed to be restarted and ever since it no longer thinks it has an Airport Card. The Airport icon is no longer on the top toolbar and if I go into the System it tells me I do not have a wireless card at all. I took the battery out and removed the card. I don't see an obvious problem, but then I don't know what I am looking for. Can anyone tell me a way to determine if the problem is with the card itself, or with the computer's ability to read the card? I would just buy a new card, but I am afraid I will put the new one in and my mac won't realize it is there either. Friend's/family are all PC users so I can't try swapping the card out on someone esles machine...Help!
Did you by any chance check to make sure it wasn't just knocked loose out of the slot when it was dropped? That would be a good pace to start.

QueenGoblin
Apr 8, 2006, 06:58 PM
yeah...I even took the card all the way out, gave it a once-over and put it back in. It seemed to be locking into place correctly. But the mac still doesn't seem to know it is there.