PDA

View Full Version : How do I format an audiobook to show up as an audiobook?




lamina
May 14, 2006, 05:58 PM
I have an audiobook in mp3 format that I downloaded from a music store (not iTunes). It shows up on my iPod in the Artists section, not audiobooks. How do I change it to appear in Audiobooks?



sonofmaug
May 14, 2006, 11:21 PM
Select the audiobook in your "Library" in iTunes, then hit "command-i" to bring up the information pane. Under the "info" section at the bottom is a drop-down menu from which you select "audiobook" as the genre.

You should be all set!

lamina
May 15, 2006, 06:00 AM
Awesome! Thanks.

esaleris
May 15, 2006, 07:30 AM
Does this work? The reason I ask is because previously, you had to rename the file into an *.m4p file or something, and even then, it didn't work.

Let us know...

sunfast
Jun 8, 2006, 02:27 PM
I think that just changes the genre but doesn't put it in the audiobooks menu

balamw
Jun 8, 2006, 02:43 PM
As has been stated, iTunes and the iPod only consider Audible and .m4b content as "Audiobooks", if you can rip to M4A you can try renaming the file to .M4B (some success), or go to the extent of using "Make Bookmarkable" from Doug's iTunes scripts or hex editing the file yourself.

There does not appear to be a way to make an MP3 audiobook show up under audiobooks.

B

milo
Jun 8, 2006, 03:31 PM
As has been stated, iTunes and the iPod only consider Audible and .m4b content as "Audiobooks", if you can rip to M4A you can try renaming the file to .M4B (some success), or go to the extent of using "Make Bookmarkable" from Doug's iTunes scripts or hex editing the file yourself.

There does not appear to be a way to make an MP3 audiobook show up under audiobooks.

B

Even that doesn't seem to work in all cases. I've converted all my audiobooks to m4b, made them bookmarkable (which seems to be working), and set the genre to audio books. No dice. Podcasts have a similar problem, they often show up under music.

Is there anything else you can do to get this to show up right?

Invizzible
Jun 8, 2006, 09:12 PM
You need to get a freeware program called "FileInfo 1.3". You can find it on Version Tracker. It allows you to change the type and attributes of different files. It's a little bit flaky, but it works. I haven't used it in a while, so I'm not positive about this, but I think in the "Type" field you have to type in M4b in order for the ipod to recognize it as an audiobook (and also type in that extension in the "Name" field). The catch is, usually the first time you do that and hit enter, FileInfo tells you it can't be done. Then, when you do it a second time, it completes the change. Weird, I know. But it works.

buffalo
Aug 8, 2006, 09:49 AM
You need to get a freeware program called "FileInfo 1.3". You can find it on Version Tracker. It allows you to change the type and attributes of different files. It's a little bit flaky, but it works. I haven't used it in a while, so I'm not positive about this, but I think in the "Type" field you have to type in M4b in order for the ipod to recognize it as an audiobook (and also type in that extension in the "Name" field). The catch is, usually the first time you do that and hit enter, FileInfo tells you it can't be done. Then, when you do it a second time, it completes the change. Weird, I know. But it works.

So I downloaded FileInfo (http://www.versiontracker.com/dyn/moreinfo/macosx/15448) but when I click on it from the download box it opens up in word as code. How do I go about opening up the program? The file is a .sit.

ljump12
Aug 8, 2006, 09:52 AM
So I downloaded FileInfo (http://www.versiontracker.com/dyn/moreinfo/macosx/15448) but when I click on it from the download box it opens up in word as code. How do I go about opening up the program? The file is a .sit.

I think you need Stuffit Expander

buffalo
Aug 8, 2006, 10:00 AM
I think you need Stuffit Expander

That worked. Thanks!

buffalo
Aug 8, 2006, 10:22 AM
You need to get a freeware program called "FileInfo 1.3". You can find it on Version Tracker. It allows you to change the type and attributes of different files. It's a little bit flaky, but it works. I haven't used it in a while, so I'm not positive about this, but I think in the "Type" field you have to type in M4b in order for the ipod to recognize it as an audiobook (and also type in that extension in the "Name" field). The catch is, usually the first time you do that and hit enter, FileInfo tells you it can't be done. Then, when you do it a second time, it completes the change. Weird, I know. But it works.

Well I wasn't able to get any change in the file to be marked as an audiobook. My goal was to be able to have the book read at the faster speed.

I selected my file...

http://img518.imageshack.us/img518/2085/picture1ui8.png

I changed the .m4a to .m4b in the Name and Type section.

http://img177.imageshack.us/img177/637/picture2gy5.png

Clicked change and got the error message as expected. Clicked change again and the file is changed as shown in files A, B, and C, in the first picture.

http://img324.imageshack.us/img324/1262/picture3rt0.png

I then updated my iPod in iTunes, but nothing appears to have changed.

Invizzible
Aug 8, 2006, 11:34 AM
Hmmm....Sorry, but I guess I can't be of any more help.:( I do exactly what you did, and the difference it makes for me is after the file is converted to m4b I can then put the audio book files on my ipod and they will automatically be put in the audio books section of my ipod. As far as playing them faster, I've never done that.

balamw
Aug 8, 2006, 11:41 AM
I then updated my iPod in iTunes, but nothing appears to have changed.
I have found that no matter how you change from M4A to M4B that you need to remove the file from iTunes completely and then re-import it.

Note also that the type can be case and whitespace sensitive so you should use "M4B " (the last character is space) instead of "M4b"

B

buffalo
Aug 8, 2006, 12:19 PM
I have found that no matter how you change from M4A to M4B that you need to remove the file from iTunes completely and then re-import it.

Note also that the type can be case and whitespace sensitive so you should use "M4B " (the last character is space) instead of "M4b"

B

Is there any way of removing and re-importing without the original CD because that has already been returned. Would burning the copies I have to a DVD/CD work at all?

I also tried the "M4B " (mine hadn't been either capatilized or spaced). When I clicked change it gave me the error message, any changes I had made before didn't bring it up, but nothing seemed to change.

balamw
Aug 8, 2006, 02:17 PM
Is there any way of removing and re-importing without the original CD
This is how I do it. Though there are plenty of ways to skin a cat. Note that I don't have iTunes on the machine I'm on so this is from memory.

Select the file in your library, right click, show song file (in Finder if on a Mac). Move the files (or even the whole folder elsewhere (like to your desktop).

Perform the M4B modification on the files at this point if it has not already been done.

Go back to iTunes and delete the entries from your library. They should all have exclamation points next to them now.

Now use iTunes' "Add to Library" function to add the modified files back to your iTunes.

B

buffalo
Aug 8, 2006, 04:09 PM
This is how I do it. Though there are plenty of ways to skin a cat. Note that I don't have iTunes on the machine I'm on so this is from memory.

Select the file in your library, right click, show song file (in Finder if on a Mac). Move the files (or even the whole folder elsewhere (like to your desktop).

Perform the M4B modification on the files at this point if it has not already been done.

Go back to iTunes and delete the entries from your library. They should all have exclamation points next to them now.

Now use iTunes' "Add to Library" function to add the modified files back to your iTunes.

B

This worked, the two tracks I tried now show up in audiobooks and I have the speed option, but the nano doesn't like the files.

When I select the file to play the sound will play normally but the screen goes into a screen freezes. It will stay on the track selection screen for a while after I selected which track to play and the sound has started. I have to click the play/pause and select buttons and then wait for the screen to catch up. Once it gets to the now playing part the screen works normally. Same thing with fast fowarding tracks. It will stay on the previous track for a while before updating...

Do you have any ideas or am I out of luck? Thanks for all the help so far.

EDIT: I also tried naming a few tracks .aa (audible) and while they stayed in the Audiobook section, it didn't help my screen problem.

cekim
Dec 12, 2008, 06:33 AM
I have an audiobook in mp3 format that I downloaded from a music store (not iTunes). It shows up on my iPod in the Artists section, not audiobooks. How do I change it to appear in Audiobooks?


I use the (free) Make Bookmarkable (http://dougscripts.com/itunes/scripts/ss.php?sp=makebookmarkable) script.

After installing it:
1. Restart iTunes
2. Select the files you want to convert
3. Choose AppleScript menu (inbetween the Window and Help menus) and then click Make Bookmarkable

balamw
Dec 12, 2008, 02:29 PM
This thread is largely irrelevant now that Apple has made it possible to designate media as an audiobook from within iTunes 8, including MP3s!

http://audiobooker.blogspot.com/2008/09/itunes-8-now-audiobooks-are-easy.html

B

jlamb0
Dec 12, 2008, 03:57 PM
I use JoinTogether. It compiles the individual CD tracks into one audio file in either .m4a or .m4b format and also gives you the option of preserving the individual tracks as chapters. I found that chapterized .m4b files made with this app showed up in my audiobooks library no problem.

You can download it here:
http://dougscripts.com/itunes/itinfo/jointogether.php

pinkskittles
Nov 11, 2009, 04:16 PM
If you select ALL the track/tracks to move to audiobooks, then go into info (ctrl+I or command I... whatever), select that you do want to edit multiple items then go to the options tab... under media kind, check the box and select audiobook.

Worked for me!!! Total fluke!

balamw
Nov 12, 2009, 07:44 AM
Holy thread resurrection Batman!

Yes, now the functionality we were trying to duplicate so hard in 2006 has been exposed in the GUI. The related MR Guide was updated to include that fact at the top of the guide.

Beyond that, the iTunes 9 GUI now allows you to designate MP3s content (and not just M4B/Audible) as an Audiobook, in case you get MP3 content from a source other than iTunes.

B

resra22
Nov 25, 2009, 05:01 PM
Beyond that, the iTunes 9 GUI now allows you to designate MP3s content (and not just M4B/Audible) as an Audiobook, in case you get MP3 content from a source other than iTunes.

so how do I do that then? Thats exactly what I need to be able to do.
First time posting on this forum but have had some great tips reading stuff.