PDA

View Full Version : songs and artwork not showing up!




fuzzn
May 17, 2006, 10:29 AM
ok i've searched and searched the forums but i can't seem to find the answer to my specific question... if someone else can then please just post the link so i can check it out... if that doesn't happen, then PLEASE help me by answering my question!

alright so... i've had my 60GB iPod (the video one) since january, and i have 3050 songs in my itunes on my pc... my ipod is set to automatically update whenever i plug it in. i have album art on many of my songs, and i can view it on itunes whenever i select a song or play it... as is supposed to be. But, when i unplug my iPod and go through the songs and select one of them, the album art does not show on some of them, and it does on the others. My iPod is set to show album art, and i know for a fact that i have added album art to the particular song, what i don't understand is why it shows up on some of the songs and not on others, sometimes on songs from the SAME album!

the other problem is that all my songs are named perfectly, but some don't seem to show up on my iPod when i'm browsing through artists or albums, now they do show up when i'm browsing through songs but that really pisses me off that i have to browse through 3050 songs each time i want that particular song! For example, i have about 7 James Brown songs, all named the same (no accidental spaces between or before/after the words), they all have the same album art also... but when i go to James Brown in 'Artists' on my iPod, only 2 of them show up!

i've tried resetting the iPod, deleting all the songs from it and uploading them onto it again, but NOTHING...

if someone can please solve both the album art and missing songs issues for me, or point me in the right direction, i'd really really appreciate it!

thanx in advance

-fuzz



fuzzn
May 17, 2006, 10:46 AM
lol also please don't hate me for my bad taste in music :p

fuzzn
May 18, 2006, 02:17 AM
bump....

come on people! isn't there ANYBODY that can help me?

balamw
May 18, 2006, 11:34 AM
More info please. MP3 or AAC. Are the "missing" files checked in iTunes.

It has been suggested before that the artwork cache can get mangled and need to be reloaded. Turn off artwork on the iPod, sync, and then turn it back on.

B

fuzzn
May 18, 2006, 11:45 AM
all the files are MP3 format. there are no unchecked files at all... i will try the artwork thing and report back!

balamw
May 18, 2006, 11:54 AM
all the files are MP3 format. there are no unchecked files at all... i will try the artwork thing and report back!
You may also want to "clean up" your ID3 tags, as iTunes can get confused with MP3s that were tagged elsewhere. I've seen some files have three sets of MP3 tags. ID3V1 and two sets of ID3V2. Bring them all up to ID3V2.3 using teh Advanced menu and you'll get the highest degree of compatibility with iTunes.

B

fuzzn
May 18, 2006, 01:24 PM
ok... so the album art thing seems to be ok, i checked a playlist of 50 songs of which only 20 were previously showing, and now all of them are! :D

so thank you soooooo very very much for that, its put a huge smile on my face!

now about the missing songs... i've found that if i browse through the songs i see them there, but when i browse the artists, it only shows a few. i found that one album i had only had 2 of the songs with an album name and the other 10 tracks did not have any album name entered. when i changed it they appeared!

BUT... i don't understand why when i'm browsing artists it doesn't show the songs, shouldn't it do that regardless of whether or not i have an album name entered? some other songs without an album name show up with their artists, but then some don't... WHY IS THIS!?!?!

mannix87
May 18, 2006, 01:30 PM
make sure your "compilations" settings are turned off. it's been identified before as a glitch on the 5G, that when this feature is turned "on", all the artists whose songs are part of compilations in your iPod will not show up on the artists' list.

fuzzn
May 18, 2006, 01:44 PM
make sure your "compilations" settings are turned off. it's been identified before as a glitch on the 5G, that when this feature is turned "on", all the artists whose songs are part of compilations in your iPod will not show up on the artists' list.

i never turned the ''compilations'' settings on... and i just checked and they're set as off on my iPod.

fuzzn
May 18, 2006, 01:46 PM
also, i should inform you that until 2 days ago i was still on the 2005-10-12 iPod updater. i thought that may have been the problem so i upgraded it to the current 2006-3-23 updater and still no luck :(

justusklemperer
May 22, 2006, 06:40 PM
Just wanted to let you know that I have the same problem (with songs not showing up). If you search by song, they all show up. If you search by artist, only the ones with an album name listed will show up. If there is only only album name, all songs will show up directly as you click on the artist. If there is more than one album for a given artist, you will go to the list of albums first and then the songs.
Another one of my friends has the same problem (even with older models), but most don't. I'm still looking for a fix (other than deleting all album names)

justusklemperer
May 22, 2006, 07:15 PM
there is a partial solution... You can push "Play" in the artist list to play all songs by the selected artist

fuzzn
May 22, 2006, 07:25 PM
wow... thank you VERY VERY much... it's good to know i'm not the only one in the whole wide world with this problem! :p

also, thanks for the PLAY on the Artist tip, will definitely do that, i'm gonna keep checking other places to try and find a solution as well as keep checking here if somebody finds one.

thanks again, appreciate it! :)

-fuzz

balamw
May 22, 2006, 07:42 PM
So why not just give the tracks a dummy album name if that's all it wants?!? :confused:

B

fuzzn
May 23, 2006, 05:26 AM
yea i would... but then again i'd love for it to work like it should!

balamw
May 23, 2006, 05:51 AM
yea i would... but then again i'd love for it to work like it should!
I think it is working as designed, and you're trying to make it work the way you think it ought to have been designed.

If you rip anything from CD in iTunes or buy it off iTMS it gets an album tag even if that tag says "Unknown Album". If you import MP3s ripped elsewhere that don't have an album tag, that really ain't iTunes' fault is it?

B

fuzzn
May 23, 2006, 09:28 AM
I think it is working as designed, and you're trying to make it work the way you think it ought to have been designed.

If you rip anything from CD in iTunes or buy it off iTMS it gets an album tag even if that tag says "Unknown Album". If you import MP3s ripped elsewhere that don't have an album tag, that really ain't iTunes' fault is it?

B

touché! :p
i suppose you're right... and i guess that is actually what it is...
thanks!