PDA

View Full Version : Why can't I make an alias?




dogbone
May 20, 2006, 09:30 PM
I'm having trouble making an alias to a specific folder. The path to the folder is

Mac/Library/Application Support/Garage Band/Instrument Library/Track Settings/Software

I can make an alias of all the folders up to and including "Track Settings", after that the alias option is greyed out. It can't be a permission issue because "Track Settings" has the same permissions as "Software" ie owner System read only Admin read only.

What is even more annoying is that it's not the 'Software' folder that I need to make an alias to but a folder inside, that is one of my added folders to which I do have full permissons and ownership. But I am unable to make an alias to that folder either.

In case you're wondering why I didn't put the sofware into my home folder, the reason is that it won't work properly in there.

Why?



mkrishnan
May 20, 2006, 09:39 PM
It might have to do with ownership of that folder, because the Make Alias command makes an alias in the same location... Try navigating to a view of the parent folder in Finder, and then drag the file or folder you want to make an alias of to the desktop, holding down Apple and Option. The icon should change to an alias arrow while you're on the desktop, and it should create an alias for it there (as opposed to in the parent folder). Then move it wherever you want it.

dogbone
May 20, 2006, 09:53 PM
That worked, thanks.

jsw
May 20, 2006, 09:54 PM
I can verify that mkrishnan is correct on all counts. First, the folder you're trying to alias is inside a folder which has read-only access (at least on my Mac). Second, the ⌥-⌘-drag-to-the-Desktop (or wherever) technique works perfectly.

Edit: too slow. But it was due to write protections....

dogbone
May 20, 2006, 09:56 PM
Yes, I can see now that the problem was that the folder could not be written to. As the folder above it "Track Settings" is read/write. I didn't know about the Cmd+Option shortcut.

Damn it was all to no avail as I wanted to make an alias to some software instruments on my mac to another mac on an ethernet network but even though we are connected to each other their garage band is not seeing the Software instruments that the alias points to.:mad:

mkrishnan
May 20, 2006, 10:20 PM
How are you making the alias? Well, erm, I just told you how to make the alias... :o But erm, are you making it on the computer that has the file on it (server) or the one you want to *use* the file (client)? If you aren't already, try mounting the disk on the client and then using the client to make the alias. You need this so that the alias is written with respect to the mounted volume and not to the root directory, I think... I don't think the OS is smart enough to catch and fix this if you make the alias on the server and then copy it over. Otherwise, you might be able to do this using 'ln -fs' in Terminal...

dogbone
May 20, 2006, 11:51 PM
Bugger this is really frustrating. I thought your suggestion was bound to work.

I mounted the server from the client and remade all the aliases and put them on the client computer but it didn't work. I tried it by putting the files in client's home library and also the client's hd library. Neither worked. Bummer.

I'm not sure how you mean to use terminal.

I also tried opening my copy of Garage Band from the client computer using a new admin account and even though it contained all the aliases even that wouldn't see the new software instruments. Very odd.