PDA

View Full Version : Battery not recharging????


leprechaunG4
Mar 3, 2003, 11:11 PM
Hey guys,

My 12" PB started doing something wierd today. The battery isn't recharging. It was sitting at 97% with the power chord symbol in the battery. I unpluged the power and let it drain to 95% then plugged it back in. Now it's sitting at 95% with that slanted z in the battery! Does anyone have any clue what's up? Is there something I can do to try to fix it, or do I have a bumb battery. I've only had the PB since Wed. It was workign great till tonight. I tried restarting but that was a no-go. Any ideas of what's going on would be greatly appreciated.

Thanks,
Nate

Steradian
Mar 3, 2003, 11:40 PM
Hey when you click on the menu bar thingy under the percent does it say charged? I have had some weird experiance w/ my powerbooks battery, and sometimes it will have a 92 chage and stop. The best way i found of getting rid of this delima is letting your battery drain compleatly, till it says 1 minute remaiming in charge then to turn off the labtop and let it charge over night. If is still dosn't charge then take it to your local apple store, assuming you live near one, and use 1 of thier batteries to determine if it's a battery problem or a problem with the labtop. Happy hunting and i hope this was somewhat useful...

leprechaunG4
Mar 4, 2003, 09:56 AM
It doesn't say charged. It says calculating till full or soemthing along those lines. The wierd thing is the light on the adapter plug stays green. Usually when it's charging that light turns orange. I'm trying what you said though. I'm at work right now and I left my PB at home turned on, hopefully it'll have completely drained the battery by the time I get home and I can try recharging it from there. If that doesn't go are there any other theories? Is it possible that it's software. I'm a newby to Macs, and being a PC guy reinstalling the OS almost always seems like the answer, does that hold true to Macs?

TheMightyG
Mar 4, 2003, 10:44 AM
Originally posted by leprechaunG4
It doesn't say charged. It says calculating till full or soemthing along those lines. The wierd thing is the light on the adapter plug stays green. Usually when it's charging that light turns orange. I'm trying what you said though. I'm at work right now and I left my PB at home turned on, hopefully it'll have completely drained the battery by the time I get home and I can try recharging it from there. If that doesn't go are there any other theories? Is it possible that it's software. I'm a newby to Macs, and being a PC guy reinstalling the OS almost always seems like the answer, does that hold true to Macs?

Hmmmm....

I had a similar problem with my old Tibook. The battery indicator on the bottom indicated that it was fully charged (4 green LEDs) and the menu bar icon stated that it was fully charged when the power adaptor was plugged in so it wouldn't charge. However, once I removed the adaptor the computer would shut off. I took the battery into an Apple Store and got a free replacement. I was told that the battery was drained, but somehow the circuitry was fritzed in a way that it still believed that it was still at 100% capacity so it wouldn't recharge from the power adaptor.

I really doubt that a software glitch is to blame. I'd bring the battery back for the propellorheads to take a look at. Is it still under warranty?

Eniregnat
Mar 4, 2003, 10:50 AM
“No memory” batteries or not, the procedure described above is good battery maintenance. From experience, it seems to lengthen the life span of batteries. I have 2 that I discharge completely before recharging, and I have 1 that I use and charge as needed.

timbloom
Mar 4, 2003, 01:04 PM
Resetting the power manager should fix this problem, it has happened a couple of times to my ibook. It is usually just full, but the computer's calculations get screwed up somehow.

Look on apple's knowledge base for instructions on how to do it on your particular machine.

leprechaunG4
Mar 4, 2003, 08:56 PM
Thanks for all the info guys. It looks like the first method is workign so far. I let the battery drain REALLY low then plugged it back in. This time the light on the adapter went orange instead of green, phew. It's charging as we speak, it's at 63% currently. Hopefully it makes its way back up to 100%. If not I'll try that power management. I did read around the knowledge articles today while I was at work.

Thanks again guys.

--edit--
It's now fully charged, thanks so much guys, you're awesome!