PDA

View Full Version : Help-Numerical key on keyboard won't work!!




emandell
Jul 6, 2006, 12:30 PM
I am on one of the 2 year old iMacs(with the dome base) running 10.3.9 and my numerical keyboard just stopped working. First thing I did after pressing every key on the keyboard was to switch keyboards with another white keyboard (numerical keys worked on it when attached to another computer), but it still doesn't work.

Went to online help which brilliantly said to "unlock the numerical keyboard lock" yeah.. well which key is that! My keyboard doesn't have the num lock on it, so that didn't help. Someone told me it was the clear key. Tried it, no change.

I found a post from this site from 2 years ago and the person said he pressed the alt key 5 times and that fixed it. Well, that didn't work for me.

The numerical keyboard does not work in any software program...I tried it with the calculator, Microsoft Word, Excel, Photoshop, Illustrator... doesn't work!

Anyone out there that can help me?



yellow
Jul 6, 2006, 12:32 PM
Have you restarted?

emandell
Jul 6, 2006, 12:36 PM
[QUOTE=yellow]Have you restarted?

I restarted...
I shut down
I yelled
I spoke nicely
I reinstalled OS software
I installed new program software

It has been over two weeks now and still nothing

yellow
Jul 6, 2006, 12:43 PM
Does it work if you log in as another user?

Also, the "clear" key on the number pad also has "numlock" on it.. this is the key you were looking for earlier.

From MacHelp:

My numeric keypad doesn't work
The way the numeric keypad works depends on your computer, the particular keyboard you are using, the application you're working in, and whether the Num Lock key is engaged. Usually, the numeric keypad is used to enter numbers in a document, but in some applications you might be able to use the keypad to navigate (move around in) your document.


Press the Num Lock key to switch between the ways the numeric keypad functions.

If you have a separate numeric keypad on your keyboard, the Num Lock key is located in the numeric keypad. If you're using a portable, the Num Lock is a function key, marked Num Lock (F6). If your keyboard has a separate keypad but no Num Lock key, try pressing Shift-Clear.

Most PowerBooks have a group of keys on the keyboard that can function as the numeric keypad. To find the keypad, look for small numbers or symbols in the lower-right corner of keys on the right side of your keyboard. Press the Num Lock key (F6) to turn on the keypad. The green light glows on the Num Lock key when the keypad is activ

emandell
Jul 6, 2006, 12:57 PM
Sorry it took so long... I logged in as another user and the number keys do work under the other user.

I tried the clear key by itself... no change
I tried the Shift and clear keys together, and that didn't do anything either.
If the clear is the num lock... it isn't unlocking for me!
Any other suggestions?

It has been over two weeks now and I am really frustrated and neeeed those numerical keys!!



Does it work if you log in as another user?

Also, the "clear" key on the number pad also has "numlock" on it.. this is the key you were looking for earlier.

From MacHelp:[/QUOTE]

yellow
Jul 6, 2006, 01:02 PM
Well, if it works on another user, that's good. It means that the problem is with your user alone, and probably in the ~/Library/Preferences/ or ~/Library/Caches/.

First step, remove the contents of ~/Library/Caches/ and logout and log back in. Doesn't help?

Second step, move ~/Library/Preferences/com.apple.Finder.plist to your Desktop, logout and log back in.

emandell
Jul 6, 2006, 01:25 PM
Look at this:123456789!!! It was in the prefs
Now everything is working just fine. So any ideas what it was so I know not to do it again?

And thanks


First step, remove the contents of ~/Library/Caches/ and logout and log back in. Doesn't help?

Second step, move ~/Library/Preferences/com.apple.Finder.plist to your Desktop, logout and log back in.[/QUOTE]

yellow
Jul 6, 2006, 03:54 PM
Glad it's fixed.. unfortunately I'm not sure how it happened.
But I think it's probably unlikely to happen again.

pantera99
Dec 19, 2007, 04:30 PM
Hi, I pretty new in Macs, now I have a Macmini and the numerical keyboard just stopped to work. I think it is something wrong with my user profile because the keyboard works for another local users on my mac. None of the keys activate its functionality and I have even tried the previous posted solution : First step, remove the contents of ~/Library/Caches/ and logout and log back in. Doesn't help? Second step, move ~/Library/Preferences/com.apple.Finder.plist to your Desktop, logout and log back in.[/quote]

but my keyboard doesn't work yet.
Do you know another way to fix this?. Thanks!!

theanimaster
Feb 12, 2008, 10:08 AM
you might have accidentally enabled a very irritating feature in the Universal Access control panel. It's the "Mouse Keys" which allows you to control the mouse with your keypad. In most cases it just gets in the way.

If you press the option key 5 times in succession this toggles it on/off. May as well do yourself a favour and pay a visit to the System Preferences>Universal Access control panel and click on Mouse Tab to change the settings. Kill the Mouse Keys. Your keypad should then function normally.

pantera99
Feb 13, 2008, 09:05 AM
Thank you Emandell!!! It resolved the problem... :) :D:o