View Full Version : All songs added after June 28th will not play remotely.

Jul 12, 2006, 01:02 AM
I'm having a really weird problem suddenly with iTunes.

Any song I've added after June 28th 2006 (100% and there are hundreds of them) won't play when I try to access them remotely using iTunes sharing - but ALL songs before this date DO play fine, and ALL songs of ANY date will play fine on the host computer.

I honestly just can't think of any reason for this at all. Almost all my songs (both that will and won't play) are ripped right from a CD in lossless format. I can't find or think of anything in common about the songs after the date of doom, and there's nothing different about them than the songs before this date.

This is what happens when I try to play a song added after June 28th remotely:

-I click on the song and press play (or double click)
-Nothing happens (like nothing - the clock doesn't start going forward, the play button doesn't change to pause and I get no error or even an indication that I pressed play). All that happens is I get the blue speaker icon next to the song, but without the 'sound wave' lines (the lines you get when the song is playing correctly).
-When I click away there is an '!' left beside the song.
-Looking at the song info gives NO indication that anything is wrong, and I can't find anything on the system console to suggest any error was thrown.

I've restarted iTunes on both machines and even re-added my entire music library. Neither of these things changed anything.

Its pretty annoying to only be able to play songs before June 28th on my laptop and have to listen to all songs after June 28th on my desktop.

Any help would be great!


Jul 12, 2006, 11:20 AM
In a shameless attempt to bump, I should also clarify that when I said I readded my entire library, I just pointed the library location to a different place and then pointed it back so that iTunes would re-index everything. I didn't actually re-add all the songs to a new location as I wanted to keep the 'date added' accurate so I could track the progress of this problem.

Jul 12, 2006, 11:22 AM
Ok, one more thing -

I've now tried this with multiple remote computers, and it fails in exactly the same way for all of them so the problem seems to be server side.

Jul 12, 2006, 11:32 AM
Might be helpful if you could tell us more about your setup, e.g. what version(s) of iTunes are you running and on what platform (Mac/Windows). What format are the files you are trying to share in M4A/M4P/MP3/MP4 ...

EDIT: I see you said CD lossless. Do you mena Apple Lossless in an M4A wrapper or AIFF or WAV?

Have you tried other DAAP clients like ourtunes (http://ourtunes.sf.net)? You might get a more helpful error message.


Jul 12, 2006, 11:59 AM
iTunes on all machines is the newest version (the first thing I do if I have a weird problem like this is check for updates, so you can be sure that by the time I'm posting here I have the latest version of OS X and iTunes on all machines involved).

All the machines involved are PPC Macs. The server is a dual G5, the client is a PB 1.67 G4 (as in my sig). I've also tried with a 15 inch PB 1.67 G4 (mine is a 17 from the previous generation) - same thing with both of them.

All the songs involved are Apple lossless, taken from a CD. M4a - the format iTunes puts them in when you specify "import in apple lossless". I doubt the format is having an impact because there are thousands of songs previous to that date imported in exactly the same way, in the same format, that work fine everywhere.

I will certainly try ourTunes to see if I can get an error message.

The only other hint I've been able to find is that many of the 'core' applications in OS X (iSync, iTunes, etc etc) were modified on June 28th which leads me to believe that is when the last OS X update happened - so maybe that has something to do with it.

Anyway - thanks for taking the time to read about my troubles!

Jul 12, 2006, 12:20 PM
I AM able to stream any songs (including ones that will not play on remote Macs) to my Airport Express in my living room - but only if I do it from the server itself. If I try to stream music to my Airport Express with my PowerBook, I have the same problem.

....so if I want to listen to music in my living room I have to VNC into my G5 to stream the music to my living room. I used to be able to just stream it using iTunes on my PowerBook while I was sitting in there which was much easier to deal with.