PDA

View Full Version : /usr/bin/osacompile




tapman90
Aug 31, 2006, 02:58 AM
okay. i want to say first of all, i'm stupid. I did somethings i shouldn't have done and now i have the following problem:

well, i'm writing an applescript application and i tried to install a third party plugin to expand the amount of applescript commands i could use. But, i didn't like the way it handled, so i tried to deinstall it. But, after i thought i deinstalled it, i started getting the error "couldn't exec /usr/bin/osacompile: No such file of directory" from xcode when i tried to compile my app. how could i fix this?

i have uninstalled and reinstalled the developer folder and have upgraded xcode, but that didn't help. This problem happens on all my applescript application projects now!

if anyone know's what i could do to fix this, that would be great!

thanks!

-tapman90



iMeowbot
Aug 31, 2006, 03:24 AM
osacompile is in the BSD subsystem package on the OS X disc. Maybe you can fish it out with Pacifist and drop it back in by hand.

tapman90
Aug 31, 2006, 05:17 PM
thanks! that worked!