PDA

View Full Version : Powerbook G3 external HD issues




loment11
Aug 31, 2006, 04:25 PM
I have a Maxtor 1-touch that I have been using on my Mac through a PCMCIA adapter to store my music. This computer crashes on me on a regular basis now.
However, the big issue comes with me wanting to escape this sinking ship. My external HD, takes multiple tries of turning on/off (so does my Ipod for the matter) to finally be recognized. During transfers, the computer will freeze with great regularity...and then the process is repeated.
Like I said, I am trying to escape, but my external drive is only recognized on this computer. I have tried another Mac (Imac) to no avail, and have tried multiple new PC's. With the PC I do get the auto recognition of a device getting plugged in, but it doesn't show up as a drive under 'My Computer.' I can only see it in the PC device manager where it is listed as maxtor One-Touch USB Device.
At this point I want to just reclaim my external drive, can someone tell me how to reformat it as a FAT32 so that I can use it with both Mac and PC?



Hilmi Hamidi
Aug 25, 2009, 11:39 AM
Most of the time in this case, is the enclosure was busted, not the drive itself.
I suggest you buy another enclosure for it and boot it in Windows PC and see if the drive works like it should be again.

California
Aug 25, 2009, 12:56 PM
I think there are known issues with these external Maxtors.

Also if you are using a usb instead of firewire, that adds to the problem on G3 Powerbooks. There is software on those one tough Maxtors that collides with OSX.

You need to reformat the drive through disc utility before you start using it on a Mac; reformatting it for OSX journaled.

Get new PATA internal hard drive for the Powerbook G3, though old, they are pretty stable on Tiger.