PDA

View Full Version : Annoying 15" PowerBook behavior...


dkeninitz
Mar 29, 2003, 10:22 AM
I've got a 1ghz 15" PB. I recently upgraded the memory to 1gb. Whenever I'm on battery power, I experience annoying response delays when working in Excel. For example, double tapping on the track pad and then dragging the scroll bar results in no apparent response for a second or so (seems like an eternity though), then the bar suddenly jumps. There are similar delays for many other actions, such as dragging a cell to fill adjacent cells, applying formatting such as bold or underline, etc. I see
the little clock while I'm waiting. Some facts:

-This was happening even before I upgraded the memory.

-This happens even with no other applications open, and with relatively compact spreadsheets.

-It happens whether the batter is fully or only partially charged. Also, I properly calibrated the battery when I first got the machine a month ago, and I get plenty of battery life from each charge.

-I've tried the "highest performance" energy saving choice, and the custom choice with "highest" processor performance selected. I get the delays regardless.

-With the power adapter connected, all of these delays go away, and response is instantaneous.

Does anyone have an idea what could be causing this? It's a mystery to me that it only happens on battery power. Thanks for any help. This is driving me NUTS!

WilliamGates
Mar 29, 2003, 08:31 PM
Since you are fortunate enough to have a Ti then Diskwarrior can be used in OS9 if you havent tried it. You can optimize (defragment) the hard drive after booting up the CD. This could be the reason with your slowed performance. Others probably have other ideas but I felt this really helped performance on my 15" 667 DVI model. Diskwarrior is incompatable with my 17" at the moment, but they are working on an OSX compatable version.

alsoft.com

Pismo
Mar 29, 2003, 09:22 PM
My brother in law has a 1 GHz TiBook as well. When he was running the TiBook off of the battery and waking up from sleep, the trackpad would not work at all. He had complete control of the computer except the trackpad. He did some research and found a solution that seemed to work...

When you're running off of the battery, Processor cycling turns on by default. If you disable Processor Cycling (in the Energy Saver prefs I think), it might fix your problem and the trackpad should work from now on. He hasn't had the problem since. Try it and let us know if it works. Good luck!

unixinit
Mar 29, 2003, 10:08 PM
this is probably caused by the little 'click' sound effect excel plays when you scroll through a spreadsheet. since, on battery, the powerbook will turn off the sound subsystem when it hasn't been used in a while, it has to cycle it back on when a sound is being played -- and this process takes a couple of seconds. turn off 'provide feedback with sound' in the excel preferences, general section.

WilliamGates
Mar 30, 2003, 05:16 AM
Also visit the Apple forums. They discuss a downloadable software that disables the sound cutoff in OSX while on battery power, but I cant remember the name. Put "popping" into the forums search engine and see what you get.

http://discussions.info.apple.com/WebX?50@210.I6ApaZFniEJ.20@.3bc0e136

backspinner
Mar 30, 2003, 07:46 AM
keepsoundawake, see versiontracker

crazzyeddie
Mar 30, 2003, 09:57 AM
It is the annoying sounds in all the Microsoft Office products. It causes the audio system to 'boot up', which takes a second.

trebblekicked
Mar 30, 2003, 11:17 AM
what about annoying issues in photoshop? for example, the shift-key works wierd. when making a marquee/shape/crop etc, holding shift keeps proportions constrained. on my tibook, the M/S/C drags out in whatever weird shape you did, only snapping to constrained proportions when you release the click! It's very frustrating.

dkeninitz
Mar 30, 2003, 03:02 PM
Thanks everyone - the sound latency appears to be the problem, because now that you all mention it, the problem is exclusively related to actions that produce sounds. I'll head for VersionTracker! Thanks again.