PDA

View Full Version : Moving files from "Music" to "Audiobook" library




williamsonrg
Sep 12, 2006, 11:22 PM
The title pretty much says it all... Audiobooks which I didn't purchase through iTunes show up in my "Music" category. Any idea how to change them to appear in the "Audiobook" list?



tk421
Sep 13, 2006, 12:04 AM
Check out this forum (http://forums.macrumors.com/showthread.php?t=200689&highlight=audiobook).

I don't know why Apple doesn't just make a check-box to make a file an audiobook. It would be so much easier.

IscariotJ
Sep 13, 2006, 03:42 AM
I've the same problem, except with audiobooks that I've ripped. They already have the m4b file suffix, and a genre of audiobooks, yet still show up in Music and not Audiobooks. Most annoying. Looks like I'll have to carry on using my smartplaylist and turn off the audiobook library through Preferences.

tk421
Sep 15, 2006, 02:23 PM
I've the same problem, except with audiobooks that I've ripped. They already have the m4b file suffix, and a genre of audiobooks, yet still show up in Music and not Audiobooks. Most annoying. Looks like I'll have to carry on using my smartplaylist and turn off the audiobook library through Preferences.

I had this problem, too. I removed the song files from iTunes, but when the dialog box asks if you want the file moved to the trash, I clicked "Keep Files." Then I dragged the files back onto the iTunes icon and they reimported into the correct place.

Good luck.

balamw
Sep 15, 2006, 02:26 PM
I had this problem, too. I removed the song files from iTunes, but when the dialog box asks if you want the file moved to the trash, I clicked "Keep Files." Then I dragged the files back onto the iTunes icon and they reimported into the correct place.

Correct. You need to remove and reimport them after conversion to M4B, not just point to the new M4B file when it tells you that the file is missing and asks if you want to find the file.... Otherwise, iTunes still considers it an M4A file.

To be completely sure this is what I am doing I usually move the file to the desktop, remove it from the iTunes folder. Do the M4B thing, and then re-add it to the Library.

B

IscariotJ
Sep 16, 2006, 04:18 AM
Correct. You need to remove and reimport them after conversion to M4B, not just point to the new M4B file when it tells you that the file is missing and asks if you want to find the file.... Otherwise, iTunes still considers it an M4A file.

To be completely sure this is what I am doing I usually move the file to the desktop, remove it from the iTunes folder. Do the M4B thing, and then re-add it to the Library.

B

This still doesn't make them appear in the AudioBooks library. ( i've just delete them, and re-imported them ). I have no problems renaming them to m4b and getting them to be bookmarkable. My issue, is that they don't show up in the correct place. There must be something else within the files that iTunes uses.

Mitthrawnuruodo
Sep 16, 2006, 04:50 AM
Make Bookmarkable v2.0

This script will change the file type of the selected AAC tracks to "M4B " and file extension to ".m4b", thus making them bookmarkable. (That is, the track will resume playing wherever you left off the last time you played it.) Additionally, when used with iTunes 7 or better, deletes and re-adds each track so it will appear in the Audiobooks Library. Ratings, play count, last played date, skip count, and skipped date are preserved.

http://www.dougscripts.com/itunes/scripts/scripts07.php?page=1#makebookmarkable

balamw
Sep 16, 2006, 10:27 AM
http://www.dougscripts.com/itunes/scripts/scripts07.php?page=1#makebookmarkable
Yeah, you want to change the ftyp atom in the file to "M4B " instead of "M4A ", while I usually use a hex editor for this, there are also scripts like the one Mitth pointed to.

That's what I meant by the M4B thing, simply changing the file extension is not enough.

B

Mitthrawnuruodo
Sep 16, 2006, 10:55 AM
Yeah, you want to change the ftyp atom in the file to "M4B " instead of "M4A ", while I usually use a hex editor for this, there are also scripts like the one Mitth pointed to.Yes, I couldn't be bothered trying to use SetFile in Terminal, Automator and/or another script, or other DIY solutions, so I just kept audio books in my ordinary library under genre Books & Spoken. Wasn't really a problem, since iTunes 6 didn't do much to distinguish them.

But after I got iTunes 7 I started poking around for a solution, and I found the above mentioned script yesterday after it was mentioned in a comment to a hint over at macosxhints, tried it, and it works like a charm... :)

JillRenee
Nov 8, 2011, 11:59 AM
Hi,

I'm operating on a PC (shutter!) and I can't for the life of me get the audiobooks I've ripped/imported to stop clogging up my main music library list. Can someone please tell a non-tech savvy person how to get these books out of my main library? :o

DrBubba
Nov 8, 2011, 01:20 PM
Moving an audiobook from your iTunes music folder to the audiobooks folder is really easy. Here's how to do it:

1. In your iTunes music folder, select the file(s) you want to move
2. Right click on the file and select "Get Info"
3. Select "Options" tab
4. Set "Media Kind" to "audiobook"
5. Click OK

The file(s) will move from your music folder to your books folder
and will be listed in iTunes as a book.

DUCKofD3ATH
Nov 8, 2011, 02:01 PM
Use a tool like FileMatch to change the audiobook file's type/creator settings to:

Type: M4B
Creator: hook

Then make sure you've got the file extension .m4b and you're all set.

I've got thousands of audiobook files with these settings and they show up in iTunes in the Books section.

[edit] You can download FileMatch here:

http://www.macupdate.com/app/mac/16538/filematch

Delete the audiobooks from iTunes; change the type/creator; then add them back into iTunes. They'll automatically go to the Books section.

Draft
Dec 15, 2011, 02:35 PM
I'm having a similar problem, but in my case, the 'Media Kind' dropdown has music selected and is greyed out. I can't even open the dropdown to change it.

Has anyone seen this before? I have iTunes match enabled. Does this have something to do with this issue?

Thanks,
David