PDA

View Full Version : Linksys WUSB54GC is working with macmini




serg77
Sep 20, 2006, 06:32 PM
Hi to all!
I was playing with this USB wireless adapter for a long made a ton of research and finaly made it work. If anybody interesting follow the guide.
1. Download drivers http://www.ralinktech.com/drivers/Mac/RTUSB%20D70-1.1.3.0%20D71W-1.1.5.0%20UI-1.2.8.0_2006_08_24.dmg
2. Install in usual way.
3. Open terminal
4. Go to /System/Library/Extensions/RT2500USBWirelessDriver.kext/Contents/
5. Open file sudo pico Info.plist
6. Edit any of key and fill with following:
<key>LINKSYS</key>
<dict>
<key>CFBundleIdentifier</key>
<string>com.Ralink.driver.RT73</string>
<key>IOClass</key>
<string>RT2573USBWirelessDriver</string>
<key>IOProviderClass</key>
<string>IOUSBDevice</string>
<key>bcdDevice</key>
<integer>1</integer>
<key>idProduct</key>
<integer>32</integer>
<key>idVendor</key>
<integer>5041</integer>
</dict>
7. Save file
8. Run this string /usr/sbin/kextcache -k /System/Library/Extensions
9. Restart computer
10. Take off card and insert back to computer.

I hope your is working too! Smile ;)



Reimer
Sep 20, 2006, 10:38 PM
thats great... but why would anyone want to use that over the Airport?

serg77
Sep 21, 2006, 03:53 PM
thats great... but why would anyone want to use that over the Airport?

Becouse its cheaper and universal if you want :)

flir67
Sep 21, 2006, 10:42 PM
good job, don't need to use that idea right now but if my airport dies, I'll have a cheap walmart backup idea for the quick fix

MGo
Oct 18, 2006, 04:37 AM
Hi serg77,
thanks for your post.
I tried it with my Cube, running on 10.3.9. No way. Upgrading to 10.4.8 helped: Then, the Linksys WUSB54GC worked with your settings, except for the key name I had to use <Cisco-Linksys>
Thats what the Profiler told me. My stick was manufactured in 7/2006, sold in Switzerland.
Unfortunately, there are two minor drawbacks in this solution for me:

1. WPA encryption is not working. WEP is connecting, but with WPA I cant get a connection. WPA was flawlessly working on the Windows PC.

2. After startup, the stick is not used. I have to disconnect and reconnect it, then it is connecting automatically to the wireless network.

Any ideas to eliminate the 2 problems are welcome. SMile.

mantastic
Oct 25, 2006, 05:41 PM
im in the terminal an i enter /System/Library/Extensions/RT2500USBWirelessDriver.kext/Contents/.What do i need to do, I dont know how to do any of the rest. so if anyone could help me with like opening the info.plist file that would be great! help please. Thanks:o

iynque
Nov 7, 2006, 01:55 AM
It is important to use the pico (nano) editor. I was trying to copy the file out of the package in finder, edit it with SubEthaEdit, and then copy it back in with authentication. This does not work, as the system will then see the extension as inauthentic and unusable. Same error happens when I try to add the Linksys Key, rather than replacing an existing Key (I just replaced the first key in the list).

Also, I had to change the key from LINKSYS to Cisco-Linksys. You might also have to change the product & vendor IDs (convert the hexadecimal values in System Profiler to Decimal) if they are different. I didn't have to do this, but it might come up.

Lastly, you don't have to reboot. After using the command /usr/sbin/kextcache -k /System/Library/Extensions just use the command sudo kextload /System/Library/Extensions/RT2500USBWirelessDriver.kext/ and wait for either an error (re-install the drivers and start over) or "loaded successfully" and a wireless connection window to appear.

I've got it running on my Dual USB 12" iBook from 2002.

iynque
Nov 7, 2006, 02:08 AM
im in the terminal an i enter /System/Library/Extensions/RT2500USBWirelessDriver.kext/Contents/.What do i need to do, I dont know how to do any of the rest. so if anyone could help me with like opening the info.plist file that would be great! help please. Thanks:o

Now that you have the folder open, type the command sudo pico Info.plist

Use the arrow keys to scroll down to the first Key (the one that looks the same as the new key). Replace each of the "strings" and "integers" with the new values.

6. Edit any of [the existing] key[s] and fill [the values] with following [new values]:
<key>LINKSYS</key>
<dict>
<key>CFBundleIdentifier</key>
<string>com.Ralink.driver.RT73</string>
<key>IOClass</key>
<string>RT2573USBWirelessDriver</string>
<key>IOProviderClass</key>
<string>IOUSBDevice</string>
<key>bcdDevice</key>
<integer>1</integer>
<key>idProduct</key>
<integer>32</integer>
<key>idVendor</key>
<integer>5041</integer>
</dict>

You might have to change LINKSYS to Cisco-Linksys, depending on the value that shows up in the System Profiler. (apple menu > about this mac > more info... > Hardware > USB > Compact Wireless-G USB Adapter > Manufacturer > is it LINKSYS or Cisco-Linksys?)

Then save the file by pushing ctrl+O or F3. The file name should be Info.plist by default, so just hit enter. Now exit by pushing ctrl+x

Now, type /usr/sbin/kextcache -k /System/Library/Extensions (or copy and paste). Allow this command to run, and in the new command line that appears when it is done, type sudo kextload /System/Library/Extensions/RT2500USBWirelessDriver.kext/ (or copy and paste).

If you don't get an error you will see "Loaded Successfully." If you don't see a wireless utility appear, unplug the device and plug it back in.

thewhitehart
Nov 7, 2006, 02:11 AM
Brilliant stuff, essential for old mac users as cards are impossible! I racked my brains for hours trying to get it to work with kubuntu - I wish linksys would acknowledge linux and just make a driver already.

iynque
Nov 8, 2006, 01:22 PM
When I reboot, I have to open the terminal and run the two commands again (type /usr/sbin/kextcache -k /System/Library/Extensions (or copy and paste). Allow this command to run, and in the new command line that appears when it is done, type sudo kextload /System/Library/Extensions/RT2500USBWirelessDriver.kext/ (or copy and paste)) followed by unplugging and plugging the device in order to make it work.

I'm kinda a newbie to all this stuff (but I learn fast!). Is there a way to have these commands run silently when I plug in the device? ...or maybe just when I log in? I don't know why it is necessary, but it seems like it is.

Any ideas?

iynque
Dec 2, 2006, 01:25 AM
I used Automator to make it happen. I just added two "Run Shell Script" commands with the two Terminal commands copy-and-pasted in. I then saved it as an application in my documents folder and set it as a startup item. For those that don't have Automator.... I dunno. The file is too big to be attached here. :/

agent.heard
Jan 4, 2007, 11:19 AM
I am trying this out on a 12" G4 mac, and having issues.

The link in the first post for the driver download no longer works, however this is the closest I could find (http://www.ralink.com.tw/Home/Support/Macintosh.html)

So I tried this driver, able to open the folder and all. But when I come down to sudo pico Info.plist, there is no previous keys or information in he file. I tried adding all the keys and strings in but still cannot get the device to work. the device is a WUSB54GC made in 07/2006. I am running 10.4.8 as well.

krystmasjones
Jan 28, 2007, 02:43 PM
I am at the point when I am supposed to be typing the command

"/usr/sbin/kextcache -k /System/Library/Extensions just use the command sudo kextload /System/Library/Extensions/RT2500USBWirelessDriver.kext/ and wait for either an error (re-install the drivers and start over) or "loaded successfully" and a wireless connection window to appear"

but instead of either of the above responses I am getting a message that it can't load the extension because it is not a bundle. I have tried this on an iMac G3 Snow and a powerbook G4. Both are running OSX.4.8. I have tried as the normal admin account and as the root account. each time it says the same thing.
Anyone with any ideals of what it is/is not seeing as a bundle?

diniscorreia
Jul 2, 2007, 06:07 AM
I used Automator to make it happen. I just added two "Run Shell Script" commands with the two Terminal commands copy-and-pasted in. I then saved it as an application in my documents folder and set it as a startup item. For those that don't have Automator.... I dunno. The file is too big to be attached here. :/

Brilliant idea :) However, who about sudo? I would prompt for a password. How did you store it in the Automator action?

Also, do you need to disconnect and reconnect the usb adapter after each restart?

By the way, got it working on a Mac Pro - the think will be wired to the network, but for now I really needed wireless :)

pizbuin
Sep 26, 2007, 04:50 PM
The WSUB54GC works OK on a G4 with 10.4.6.
I run kextcache and kextload at startup but have to unplug and plugin the USB adapter before the WirelessUtility finds "the Device" (before that it displays "no Device!")

Does anyone how to solve the problem of unplug/plugin everytime?

lemmywinks
Dec 4, 2007, 06:05 AM
Hi all, i got a WUSB54GC.

Is there anyone who had luck getting it to work with leopard?
Is there somewhere i can get the correct drivers to make it work?

Damn linksys....... write a driver for it!!!

MacNoobster
Jan 6, 2008, 05:39 AM
After "Succesfully loaded" I plug in the USB stick and the Wireless Utility starts. I now want to connect, but it doesn't work. I use WPA-PSK with TKIP security. I also added the MAC address to the router's table. The router is recognizing the iMac.
It's not security of my router as I removed all and tried to connect and didn't work.
The Utility instead crashed now and then and on the Statistics tab there are a lot of CRC errors.

Anyone knows what to do?

Also, do I need to change anything in network preferences?

Thank you.

infotek
Mar 3, 2008, 08:19 PM
=================================================================================

iMAC 400MHz PPc

Os X 10.4.11

Linksys Compact Wireless-G USB Adapter
Model No: WUSB54GC
Manufactured 09/2007

Information found in System Profiler
USB device info:
Version 0.0.1
Manufacturer: Cisco-Linksys
ProductID: 0x0020
VendorID: 0x13b1


1. Download drivers:
http://www.ralinktech.com.tw/data/RTUSB%20D70-1.1.3.0%20D71W-1.1.7.0%20UI-1.3.0.0_2006_11_10.dmg
2. Install in usual way.
3. Open terminal
4. cd /System/Library/Extensions/RT2500USBWirelessDriver.kext/Contents/
5. sudo vi Info.plist
6. Edit any of key and fill with following:


<key>LINKSYS</key>
<dict>
<key>CFBundleIdentifier</key>
<string>com.Ralink.driver.RT73</string>
<key>IOClass</key>
<string>RT2573USBWirelessDriver</string>
<key>IOProviderClass</key>
<string>IOUSBDevice</string>
<key>bcdDevice</key>
<integer>1</integer>
<key>idProduct</key>
<integer>32</integer>
<key>idVendor</key>
<integer>5041</integer>
</dict>


7. Save file
8. sudo /usr/sbin/kextcache -k /System/Library/Extensions
9. sudo kextload /System/Library/Extensions/RT2500USBWirelessDriver.kext/
10. Take off card and insert back to computer.


=================================================================================

cozie321
Mar 11, 2008, 06:41 AM
Hi would somebody explain how to use the Terminal, I am new to the Mac and I can not get the info.plist to open in the Terminal.

I have installed the drivers and the program is in my applications, but when I open the Terminal I can not open the info.plist to edit it. Any help would be greatly appreciated!

Thank you ,

Marcos

iynque
Jul 2, 2008, 12:15 AM
Hi would somebody explain how to use the Terminal, I am new to the Mac and I can not get the info.plist to open in the Terminal.

I have installed the drivers and the program is in my applications, but when I open the Terminal I can not open the info.plist to edit it. Any help would be greatly appreciated!

Thank you ,

Marcos
type
sudo pico Info.plist

confusedmime
Jul 4, 2008, 11:33 PM
Problem Solved Much thanks for this !

philstone
Nov 19, 2008, 10:30 AM
Hi,
Im trying to get this to work with my PowerMac but the original download from ralink has now gone... has anyone got anew link to it? Tried the RT2500 but that doesnt work...

Please help!!

Thanks

150425
Dec 9, 2008, 06:31 PM
Thanks for the help, worked perfectly, is there a need to provide a fully automated install app or whatever you would call it? I am not familiar with these terms, the first time I did something like that, its fun!. I could create one with installer, using a slightly different way but it works.
Cheers Chris

scoutfinch
Dec 13, 2008, 10:00 PM
Thank you very much for this tip you brilliant OP! This Linksys adapter is beautiful...and I am thrilled to be able to use its shiny goodness on my iBook. :)

falterego
Dec 29, 2008, 12:50 AM
Everything seems to have worked correctly for me. I installed the driver, edited the info.plist file, reloaded the extensions and restarted. I opened system preferences > networking and it tells me I have a new ethernet connection. Then when I opened the wireless usb utility it seems to crash immediately. I've done a full uninstall and reinstall of the driver several times and I keep getting the same result with the wireless utility not opening for me.

I have a Mac Mini G4 1.25GHz with 512 MB memory running OS X 10.4.11. Anyone have any idea what I can do to fix this?

njbrideau
Feb 13, 2009, 10:36 PM
Hi,
Im trying to get this to work with my PowerMac but the original download from ralink has now gone... has anyone got anew link to it? Tried the RT2500 but that doesnt work...

Please help!!

Thanks

just download their latest driver here:
http://www.ralinktech.com.tw/data/drivers/RTUSB%20D71w-1.2.4.0_D2500-1.1.3.0%20UI-1.6.8.0_2008_12_04.dmg

and follow the directions by iynque. they worked for me like a charm. (Powerbook G4 1.67Ghz) Thanks.

hugoking
Feb 24, 2009, 03:35 PM
If anyone is having difficulty with the terminal part there's a thread over at Insanely Mac:
http://www.insanelymac.com/forum/index.php?showtopic=33913
It has a modified driver you can download with just a simple bit of terminal copy&paste text to finish.

It worked for me G5 10.4.11, belkin router and a WUSB54GC Linksys Wireless USB adapter.

MAC-PRO-DEMON
Feb 24, 2009, 04:59 PM
Every time I use a linksys router with any of my macs, they break...

So in my opinion, use linksys, your fu****

Jack

Warstrong
Apr 20, 2009, 01:43 PM
actually, the best way to get this adapter working is this:

http://www.insanelymac.com/forum/index.php?showtopic=151237

MAC-PRO-DEMON
Apr 20, 2009, 01:50 PM
Please don't resurect old threads... The last post was in FEBRUARY

Thanks,
J