PDA

View Full Version : InDesign is adding inset to imported shapes.




dogbone
Oct 10, 2006, 01:21 AM
This one is really weird. I draw a shape in Illustrator save it. Import into an InDesign box, size it proportionally to the box, then fit box to image.

BUT, there some inset usually on two or three sides ?!

I can see that the inset is caused by the InDesign bounding box for the shape not being tight and ID uses it's bounding box to fit the picture box, but I don't know why it is doing this.

When I test this using a standard shape like an elipse it is OK, sometimes it is OK for a shape I draw, quite often the inset is inconsistent.



dogbone
Oct 10, 2006, 06:33 AM
I've done some more testing and this is driving me fricking crazy.

The posted image is from left to right, a pen drawn path, a pencil drawn path and a pencil drawn path with a stroke. All done in illy, then placed on the same page in three boxes in InDesign.

Then sized proportionally then pressed the 'fit frame to content' button.

As you can see the left one has quite a lot of space still on two sides a bit at the top and none on the right. The middle one is almost how it should be but with some space on the bottom. The right hand image has a little bit of space all the way around.

There seems to be no rhyme or reason and I can't find any repeatable pattern to this crazy behaviour.

dogbone
Oct 10, 2006, 08:39 AM
here's another series of random shapes. The pointy shapes are OK (but they aren't always) in the rounded shapes you can see that occasionally the bounding box fits but more often than not it doesn't and the bit that doesn't fit and by how much changes sides and ammounts.

JasonElise1983
Oct 10, 2006, 08:46 AM
don't really know why that is suck a problem, but a way to work around that when dealing with simple shapes is to copy and paste them into Indesign from Illustrator. It will retain the vector shape and allow you to change the color from within InDesign. I do that with almost all basic vetor shapes and logos. Just easier for me to work with. Give it a shot. I know there are some preferences in ID and Illustrator that you have to change first, but give it a shot.
-JE

dogbone
Oct 10, 2006, 09:24 AM
Ok thanks yes copying and pasting, (or pasting into, in this case) does solve the problem. Which got me exploring it a bit more and I have discovered that there is an option in the 'place' command if I have 'other options' checked to 'crop to art' as opposed to the default 'crop to bounding box' that also fixes the problem.

But it doesn't explain why Indesign seems to set a random bounding box?! Although I don't need to know why, to make it work.