PDA

View Full Version : Very odd USB problem - iBook G3




Xenesis
Oct 23, 2006, 03:44 AM
Hi all, I took apart my iBook G3 (as with this thread (http://forums.macrumors.com/showthread.php?t=244652)) to swap Hard Drives.

However, I discovered to my surprise that my USB ports worked again. With the case off the computer, the USB ports work perfectly fine..however when I put the case back on the computer, I found that the USB ports didn't transmit data, just run power through it.

Any ideas?



mad jew
Oct 23, 2006, 06:24 AM
Does it look like a cable is getting squashed or is close to something hot?

Xenesis
Oct 23, 2006, 06:55 AM
See, I don't imagine it would be a cable squash, as the USB Ports feed straight into the logic board, no cables or anything.

Heat is definitely a possibility, the little machine gets seriously overheated these days at times...but the only thing that ran noticably hot was the old hard drive, which I've now swapped out for a new one (It runs cooler and better).

That being said, I might just have to disassemble the bugger again. :confused: I suppose I could remove the internal metal casing over the thing...but apart from running the laptop open, I can't really think of much to do.

mad jew
Oct 23, 2006, 07:04 AM
Yeah, that does suck. I was referring to any cable, not a USB connector cable per se (as you say, it doesn't exist). It's a long shot but a restriction of throughput (especially of power) in another area on the logic board might be causing this. Admittedly it's a long shot though. :o