PDA

View Full Version : PowerBook G4 Kernal Panic




julioflacos
Dec 6, 2006, 12:01 AM
Dear world,

I was using my G4 as a target drive on my MacBook Pro and did not properly shut down my G4. Now all I get on the G4 is the kernal panic message. I have tried rebooting to no avail. I tried resetting the PRAM (?). No dice. I tried to reinstall the original OS and it did not show me anywhere to install it. How bad is this?



mad jew
Dec 6, 2006, 06:01 AM
Okay, at what stage does the kernel panic screen come up? Is it as soon as you press the power button or is it after the grey screen or is it occurring at a different time altogether? Are you saying that when you boot form the OSX discs it can't find the hard drive but it doesn't panic? :)

Angrist
Dec 6, 2006, 08:30 AM
Your file system is all fouled up. There are probably overlapped files.
(I'vev had this happen when power died during an install, and when ramchips have died.)

Boot into single user mode and run fsck.
That'll PROBABLY give you overlapped extent errors.
Which the only way I've been able to fix is with a copy of DiskWarrior.
Unfortunetly, if something really important was overwritten, then you may need to re-install.

julioflacos
Dec 6, 2006, 10:43 AM
Mad Jew,

It panics shortly after the grey apple screen. That is correct, when trying to reinstall it asks me which disk I would like to install it on but does not show the Mac HD (or any other disk for that matter).


Angrist,
How do I boot into single user mode and what is fsck? I tried booting up with Disk Warrior but it failed.

Many thanks to you both. Julio

Angrist
Dec 6, 2006, 04:30 PM
Reboot and hold cmd-S

you should get a black screen with white text and a command prompt.
Type:
"/sbin/fsck -fy" and hit enter
This'll run a disk utility to check and (hopefully) repair your filesystem. (FileSystemChecK

Booting from DiskWarrior shouldn't fail if it's afile problem ... sometimes it just takes a LOOOONG time to boot from that CD. I'd say try again and let it sit for a half hour at least.

julioflacos
Dec 7, 2006, 04:52 PM
Angrist,

You're going to love this: I did the reboot cmd S and the screen came up, displayed some text then did a kernal panic. How's about that?

Angrist
Dec 8, 2006, 10:00 PM
Hmmm

Yank your RAM, and Airport card, then try again.

If that doesn't work ...... boot into target disk mode and run DiskWarrior from another machine.

If THAT doesn't work ... then you may have a hardware problem.

julioflacos
Dec 22, 2006, 12:59 AM
Angrist,
Thanks. I took it to someone who did something and now it seems to be ok but I will refer to this thread in the event of further disaster. Best holiday wishes.