PDA

View Full Version : CD stuck in mini drive




Mr. DG
Dec 10, 2006, 10:07 AM
Help! A CD has become stuck in my mini's CD combo drive. The thing is, it doesnt seem like a physical problem because I've tried holding my mouse button down at startup; and the command from terminal.

When I go to burn a disc in itunes, the error message 'Disk burner or software not found' comes up. It also comes up as 'no device found' in System Profiler.

Is there such a thing as a cd driver i can download?

I may have done this myself. I deleted a bunch of files to do with Parallels because I wanted to install boot camp, but was unable to partition my drive because 'system files' could not be moved, and i read on here that deleting parallels files would allow me to do so. It didn't in the end.

I'd reinstall OSX from my DVD except of course I can't get the DVD in the drive...

I'm on 10.4.8.



Zwhaler
Dec 10, 2006, 11:42 AM
Hmm, I had a similar problem with a CD stuck in the drive, and was unable to get it out. But my friend came over and he just turned it on while holding the mouse button down (like I had several times with no success) and for some reason it worked when he did it. So I guess it just takes some sort of magical touch. Sorry because this doesn't really help you, but I'm sure that there is some way of getting it out.

4JNA
Dec 10, 2006, 02:18 PM
what changed? has the mini been opened?? can you hear it spin up at boot?

drive (hardware) is not being seen, so either hardware failure, or loose connection. if the mini has been opened, i would bet on a loose connection. have seen several with the same symptoms. all of mine have been as easy as re-seating to fix.

if you are still under warranty or applecare, time to take it in and get some help!

adrianblaine
Dec 10, 2006, 02:21 PM
I had this happen with my iBook. I think it came disconnected internally. It would still spin but OS X did not recognize that I had a cd-rom. I took it to an Apple store and they got out the CD and reconnected it. It seems to be working fine since then.

Mr. DG
Dec 10, 2006, 05:43 PM
Its never been opened. The only changes have been in software (updated to 10.4.8 recently) but i couldnt say it was that for definite as i rarely put a CD / DVD in the drive. Its still under warranty. I think Im going to have to call apple. Is that screenshot of system profiler right? Does that always show up like that or does the info change when you put a disc in?

Maxwell Smart
Dec 10, 2006, 08:22 PM
I believe I know what your problem is, I had this happen too (sort-of). I wanted to burn a cd and Toast told me that no CD burning hardware was installed and when i checked the profiler it looked like just a plain dvd drive. Well it turns out that the problem was because I had parallels running, and it utlizes the CD drive and virtualizes it for the virtual machine. After I shut down parallels it got rid of the problem. I think your issue is that some parallels files are still partially loaded on the system or something. I would reinstall parallels like you had it before, then exit parallels and see if it fixes your problem. Hopefully this will help.

4JNA
Dec 10, 2006, 09:42 PM
...Is that screenshot of system profiler right? Does that always show up like that or does the info change when you put a disc in?

nope, not right. it should be reporting the hardware specs of your drive. not there is not good. :(

63861

the only field that changes is the 'media' field. mine showing no disc in the drive.