PDA

View Full Version : 12" Powerbook G4 Start-up Issues




MRayJr
Dec 10, 2006, 10:38 AM
First off, I've done a search on these problems and can't seem to find anything on it.

My PB when it boots will go to the white screen with the Apple logo and wheel animation just fine. However, when it goes from this screen to the "Loading Mac OS X" screen, the display is flashing random colors for a split second before changing screens.

I've had the problem before and fixed it, but can't really remember what the problem exactly was.



Also, recently I've had problems with the PB shutting off when the screen is touched or when I set it down.

For instance...I'm lying in bed as I type this, with the PB resting on my chest. If I try to adjust the angle of the screen, or set it on the bed, it will shut down completely. I have taken the battery out and am running it solely on the A/C adapter, because when it does shut down with the battery in, it refuses to power off or restart. It's inactive yet the fan still spins.


Any help is greatly appreciated.


- Mike



MRayJr
Dec 10, 2006, 10:58 AM
I'm now posting from my phone because the PB shut down and won't restart. It now has either just a black screen or grey screen on startup.


There's no chime now, and the fan spins loudly and sporaticaly (sp?) immediately when I press the power button.

Any ideas?

mad jew
Dec 11, 2006, 05:13 AM
Can you boot it from the OS discs? :)

2nyRiggz
Dec 11, 2006, 05:56 AM
Try loading up the install disk and running permissions from there and see what it comes up with. Last time someone screen starting flashing it was the PRAM that needed resetting but it never shut down...so give it a go.



Bless

California
Dec 11, 2006, 11:30 AM
My combe 12" PB 1.5ghz did that from start up. But I sold it. New PB 1.5ghz Superdrive does not do it. I thought it was a video card problem that Applecare should fix. And I didn't want to. But I don't recall ever resetting pram on it; tho I have on the Superdrive 12".

mklos
Dec 11, 2006, 11:57 AM
Normally if a mac doesnt chime then there is a hardware issue. Possibly a Logicboard going for the details of your last post. 

Have you tried taking the battery out, unplugging it and then pressing the power button a couple of times to cycle the power out of it? Then put the battery in and try it. To see if it actually tries to boot. 

If nothing works then you may want to see if an Apple Store can do anything for you.

MRayJr
Dec 11, 2006, 12:28 PM
Well, it's back on. It took me most of the day to even get it to boot, but it did. I'm just...not touching it for the sake of keeping it running.

It's odd. I've reset the PRAM/NVRAM/PMU multiple times in the past few days it hasn't been working. Judging by my searching on this board, I concluded that it's probably the logic board.

Is it normal for the logic board to begin "going out" as opposed to just up and quitting all together? I guess that's my real question.

But otherwise, it's in working order currently. Unfortunately it doesn't have AppleCare. Maybe now it's just a good time to upgrade to a MBP?


Anyways, thanks for the help guys. These are my first posts on this board (long time lurker/reader), and I'll surely be back if I have any other issues.