PDA

View Full Version : 17" powerbook g4 just wont start?!?




applemacmad
Dec 22, 2006, 05:18 PM
After getting in from work today i found my powerbook just wouldnt start up. I usually leave it awake all of the time and when i'm not using it just dim the display - but when trying to brighten the display it didnt work, so i shut it down.

When turning it on again it made some noises and then the start up sound but wouldnt go further and the display was still blank. After trying again it wouldnt even make a noise (which ever disk starting up) or the chime.

I've tried resetting the PRAM but that doesnt work.
I cannot insert any CD's into the superdrive, they wont go in, its like the gear isnt right to accept any disks.
If i remove the power cord the laptop immediately shuts down.

It just seems to be on bot doing nothing, it wont make any noises or chime.

All i've managed to get it to do so far it get the "num lock" light to turn on and off by pressing the volume up button.



Am i missing something here? any suggestions would be most greatfully appreciated.

j



mad jew
Dec 22, 2006, 08:35 PM
Press the volume key a few times to make sure it's not muted. If you boot holding COMMAND-S, can you get into Single User Mode? :)

2nyRiggz
Dec 22, 2006, 09:14 PM
So you are not even hearing the drive spin up...How is that power button..how does it feel..is it a normal press and release?


Bless

applemacmad
Dec 23, 2006, 11:17 AM
The powerbook definately isnt on mute. By pressing command s i cant get into single user mode.

the power button seems fine, when i press it i know it had turned on, i can hear some noise, but no noise of the hard drive starting up and spinning, and a completely blank screen...

I really have no idea whats wrong :(



j

lamina
Dec 23, 2006, 11:32 AM
Have you tried holding down the power button while the machine is off until the little light on the front blinks? It'll likely make a loud BOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOP noise so don't be alarmed.

applemacmad
Dec 23, 2006, 01:11 PM
Just tried holding the power botton down whill off, ...no, didnt work, no light or sound however thank you anyway.

j

Deputy-Dawg
Dec 23, 2006, 03:30 PM
My G4 powerbook did the same thing, well it really just shutdown suddenly and would not restart, a week ago. Took it to the local service provider (70 miles round trip) who diagnosed it as a bad motherboard. Sent it off to Apple Care who replaced the motherboard ($329 since it was out of warranty and Apple Care). In any event it is back and in working order.

mad jew
Dec 23, 2006, 04:51 PM
Yeah, I agree. This is a job for Apple, or at least a certified technician. :o

applemacmad
Dec 23, 2006, 05:53 PM
yes, seems to be the case. Im off to the apple store tomorrow (regent street), hopefully its nothing too serious.

Thanks for all your suggestions guys.


j

mklos
Dec 23, 2006, 09:16 PM
Have you tried, unplugging it, taking the battery out, and pressing the power button a few times? This will do whats called power cycling it. Then plug in the power adapter ONLY and try it.