PDA

View Full Version : Powerbook G4 Disk Utility issues




nuzreq
Dec 28, 2006, 01:49 AM
First things First:
12 inch powerbook
1 ghz processor
512 ram
10.4.8

Recently i noticed that some of my apps weren't as responsive as they had been in the past, I definitely need to upgrade the ram at some point. Just to make sure there wasn't anything wrong with my internal drive i ran disk utility. I selected verify disk and then the whole system locked up, forcing me to shut down and reboot. I have tried running "verify disk" two more times and each time it ends with the same result.

Does anyone have any idea of what's going on? For the most part my system runs fine (except for the slow down) but a service from disk utility locking up my system has me worried.



Aniej
Dec 28, 2006, 01:52 AM
had something, similar, but far worse happen to me. From that experience I suggest: 1. use your 10.4.8 startup disk to run disk utility 2. back up files 3. archive and install.

nuzreq
Dec 28, 2006, 01:55 AM
use your 10.4.8 startup disk to run disk utility 2. back up files 3. archive and install.

Startup disk as in the install dvd? The most recent one I have is the original tiger install disk. Damn, that's going to be a lot of software updates. :(

Aniej
Dec 28, 2006, 02:00 AM
you have 10.4.#?

Aniej
Dec 28, 2006, 02:00 AM
and yes as in the start up cd for 10.4

mad jew
Dec 28, 2006, 02:29 AM
Before reinstalling, try repairing the disk from Disk Utility on the OSX discs that Aniej mentioned. Do that, or run fsck (http://docs.info.apple.com/article.html?artnum=106214). :)

Angrist
Dec 28, 2006, 08:56 AM
I had the exact same thing happen to me with my 1.33 Pbook about a month ago.

Your RAM is probably bad. (Mine was.)
Pull the stick, then try to run disk utility.
If everything runs fine (other than the incredible sloth of 256Mb), then it's time to buy an upgrade. 1 Gb sticks for those machines are only about $120 nowadays, and worth every penny.

If you still have problems with the RAM pulled, then get memtest (http://www.memtestosx.org) and run that to check your soldered-on RAM. If that RAM is bad ... then your logic board would need to be serviced ... I think.

nuzreq
Dec 29, 2006, 01:54 AM
I called up one of my friends, a Mac Genius, and apparently the problem was an "Illegal Name". I don't really know what or how the issue came about, but the easiest solution was to back everything up and reinstall the OS.

Thanks for all the suggestions and help.