PDA

View Full Version : You are unable to log in to the user account [name] at this time




Seahorse
Dec 31, 2006, 12:42 PM
My MacBook Pro (OS X 10.4.8) has suddenly locked me out!

When I try to log in (only one user, with admin privileges, FileVault switched on) it rejects the login saying "You are unable to log in to the user account "Adam" at this time". (Read on: it gets worse...)

I'm certain the password is correct (and correctly typed, no caps lock, keyboard working properly etc.).

When it lets me use the master password to change the user password, and I try to do so, I get the same error message and cannot log in.

If I boot from the OS X installation disk I can repair the hard drive (no errors found) and repair file permissions (a few repaired) and I can (apparently) change the user password. But when I reboot from the hard drive and try to log in, with either the new or the old password, I cannot.

I see that the error message ("You were unable to log in...") was introduced by Mac OS X 10.4.6 Update (delta), and it appears when trying to log in as a FileVault-protected user if the protected Home image file has been damaged or moved.

This makes sense. If I type in the wrong password I get the shakey thing. The right password gives me the error message.

Any suggestions? I really don't want to reinstall OS X as it'll be a major task and I've done a significant bit of work since my last backup. Is there some way I can create another user as a workaround, or restore whatever's damaged, or something?

A solution to this would save me a day or two's work so I really hope you can help!



clevin
Dec 31, 2006, 01:00 PM
http://docs.info.apple.com/article.html?artnum=303411
this exactly fit your description.
im sure there is a solution other than re-install OSX, just calm down, and be patience... and search, of course. :D

can u turn off filevault through boot-disk?

it looks like your FileVault image is damaged

Seahorse
Dec 31, 2006, 02:10 PM
Thanks for the URL - that's the article that told me what the 'unable to log in' message actually meant.

No, cannot switch off FileVault when booted from the installation disk.

What I have just managed to do is switch on the root user account and log into that. But that account doesn't have FileVault switched on and I can't work out how to switch it off for my old user account, nor how to access my old user account files while logged on as root.

Feels like I'm half way there. Any suggestions would be much appreciated!

clevin
Dec 31, 2006, 02:12 PM
back up your file and create a new acc? should be last resort.

stannum
Jan 7, 2007, 11:08 PM
Have you had any luck with this problem?

I've made it as far as attempting to mount the image but getting an I/O error.

Seahorse
Jan 8, 2007, 04:51 PM
Have you had any luck with this problem?
Unfortunately not. I got as far as I could, with help from this forum and also the Apple discussion groups on their website, but still no joy. So reinstalled everything. Fortunately I had backed up not all that long ago. And there was that pleasant, fresh feeling of a clean OS install!

Lesson 1 of the day: never, ever use VileFault

Lesson 2 of the day: back up often

Thanks to all those who gave their advice.

emchan
Sep 30, 2007, 11:22 AM
I just ran into the same problem, but fortunately, it was curable.

First, I converted my account to Filevault, then I tried to login. I met with the same error about logging in, so I rebooted. That didn't fix the issue. Fortunately, I had a backup admin account, so I probed around the system. Here are the steps I took to solve the issue.

1. Reboot
2. Login as an alternate user (Apple-S at bootup will get you a root shell if you don't have an alt)
3. Run disk utility to repair disk permissions
4. Check for /Users/.<username>. This is a cookie that is generated when you are logged in as a filevault user. I found that Filevault failed to delete this cookie when it was done, so my account was locked out. I looked in this cookie folder to make sure it was empty, then I promptly moved it to /tmp. That fixed my issue.

If that doesn't fix it, try repairing disk permissions on the sparseimage as suggested earlier.

It would be nice for future versions of OSX/Filevault to check for this cookie upon login/reboot and clean it up if necessary.

S-22
Dec 2, 2007, 04:43 AM
I just ran into the same problem, but fortunately, it was curable.

First, I converted my account to Filevault, then I tried to login. I met with the same error about logging in, so I rebooted. That didn't fix the issue. Fortunately, I had a backup admin account, so I probed around the system. Here are the steps I took to solve the issue.

1. Reboot
2. Login as an alternate user (Apple-S at bootup will get you a root shell if you don't have an alt)
3. Run disk utility to repair disk permissions
4. Check for /Users/.<username>. This is a cookie that is generated when you are logged in as a filevault user. I found that Filevault failed to delete this cookie when it was done, so my account was locked out. I looked in this cookie folder to make sure it was empty, then I promptly moved it to /tmp. That fixed my issue.

If that doesn't fix it, try repairing disk permissions on the sparseimage as suggested earlier.

It would be nice for future versions of OSX/Filevault to check for this cookie upon login/reboot and clean it up if necessary.

Hello, I have delete the sparseimage file in /Users/.<username>. and reboot, it still said 'You are unable to log in to the user account "username" at this time'.

Are there anyway to resolve this problem?

Thanks.

rx7crazy
Jan 8, 2008, 12:24 AM
Strangely I was able to login to my account, it was giving me the same error on at the login screen, using a shell as root, but that proved useless as I still was not able to access any of the accounts files. So i clicked on machintosh hd on the desktop, and then went into users and clicked on the my account. When clicked on the filevault image I put my password in and I was able to get complete access to the files again. Hope this helps you out.

Lanzelot
Jan 15, 2008, 10:17 PM
How do I do this:

Apple-S at bootup will get you a root shell if you don't have an alt
I'm sorry i'm completely new with mac, I only see a black screen but dont know what to type....:confused:


Originally my problem was that Entourage opened two windows one called: "Main Identity" and another one called: "Main Identity 2". So I deleted a bucnh of things from the Users folder (they still are in the trash can) and when I re-stared could not log on...

So If I can only get into the computer and move everything back from the trash to the the original location should fix it, but as I said, I don't know...

Please help I'm deperated!:eek:

Thank you very much!














Strangely I was able to login to my account, it was giving me the same error on at the login screen, using a shell as root, but that proved useless as I still was not able to access any of the accounts files. So i clicked on machintosh hd on the desktop, and then went into users and clicked on the my account. When clicked on the filevault image I put my password in and I was able to get complete access to the files again. Hope this helps you out.

chenr2
Aug 7, 2008, 08:56 AM
I disabled FileVault and let it decrypt. After it completed, I tried to login but received the error: "you are unable to log in to the user account 'username' at this time". I know the password is correct, because when I purposely enter the wrong password it will shake. Unfortunately, I forgot the Master Password. Here are things that I tried that did not work:

-AppleJack
-Disk Warrior
-Repair permissions
-Repair disk
-Unable to "change password" from the Administrator account because it was grayed out
-Created an image in Target disk mode, and was able to view the files but in Read-Only

I tried copying the profile and was able to log into the new profile. Please see oahu_michael's post on http://www.mac-forums.com/forums/showthread.php?t=79421 which begins with "Ok success I believe". Below are steps that I took:

How to copy a user's profile:
-Enable Root
-Log in as Root (not Administrator)
-Enable hidden files. Within Terminal, type:
defaults write com.apple.finder AppleShowAllFiles TRUE
-Then type:
killall Finder
-Within the /Users folder create a new folder with the new username
-Copy all items from old profile to the new folder
-On the new profile folder, open "Get Info"
-At the bottom, expand the Details: triangle
-Click on Apply to enclosed items... and click OK
-In System Preferences > Accounts, create a new user with the same name as the new folder
-It may say "A folder in the Users folder already has the name "username"... Click OK
-Click Show All and restart
-Log in as the new user

Good luck.

robotic2
Apr 18, 2009, 11:34 PM
Thanks to chenr2 for sharing the details of your solution. I had the same problem and followed your steps. Perfect.

Jethryn Freyman
Apr 19, 2009, 04:22 AM
Filevault possibly screwed up because you were running an outdated version of the OS (10.4.8.)

My Filevault account on 10.5 hasn't caused any trouble, even through multiple kernel panics.

DarrenSanzkrit
Jun 30, 2010, 04:50 AM
i have been having this problem for 2 days. Finally after a lot of reseach i have managed to create a new user account but i'm am still logged out of my old one. When i try to Repair Disk Permissions it says "Error: No Vaid Packages"
Any ideas how on what is wrong? Thanks so much

belvdr
Jun 30, 2010, 05:03 AM
Are parental controls enabled on that account with time restrictions?

iHackstuf
Apr 14, 2011, 04:19 PM
My MacBook Pro (OS X 10.4.8) has suddenly locked me out!

When I try to log in (only one user, with admin privileges, FileVault switched on) it rejects the login saying "You are unable to log in to the user account "Adam" at this time". (Read on: it gets worse...)

I'm certain the password is correct (and correctly typed, no caps lock, keyboard working properly etc.).

When it lets me use the master password to change the user password, and I try to do so, I get the same error message and cannot log in.

If I boot from the OS X installation disk I can repair the hard drive (no errors found) and repair file permissions (a few repaired) and I can (apparently) change the user password. But when I reboot from the hard drive and try to log in, with either the new or the old password, I cannot.

I see that the error message ("You were unable to log in...") was introduced by Mac OS X 10.4.6 Update (delta), and it appears when trying to log in as a FileVault-protected user if the protected Home image file has been damaged or moved.

This makes sense. If I type in the wrong password I get the shakey thing. The right password gives me the error message.

Any suggestions? I really don't want to reinstall OS X as it'll be a major task and I've done a significant bit of work since my last backup. Is there some way I can create another user as a workaround, or restore whatever's damaged, or something?

A solution to this would save me a day or two's work so I really hope you can help!


How to make a new admin account from single user mode (Shut down, start up, -s when you see the screen turn on, keep holding until text appears.)

Type this:
/sbin/mount -uw /
and hit return

type this:
rm /var/db/.applesetupdone
and hit return

Then type this:
reboot
hit return, and your Mac thinks it hasn't been set up yet, play the video (Yay) and you can create your new account:)


Note:
It will ask you about importing data; DON'T CLICK YES! Your stuff is still there, safe and sound!

MrPook20
Sep 29, 2011, 01:06 AM
How to make a new admin account from single user mode (Shut down, start up, -s when you see the screen turn on, keep holding until text appears.)

Type this:
/sbin/mount -uw /
and hit return

type this:
rm /var/db/.applesetupdone
and hit return

Then type this:
reboot
hit return, and your Mac thinks it hasn't been set up yet, play the video (Yay) and you can create your new account:)


Note:
It will ask you about importing data; DON'T CLICK YES! Your stuff is still there, safe and sound!


Thank you iHackstuf for your post. I am helping my buddy out with this same issue. We followed what you said and it worked but we now want to get the documents that are on the old user account. we are not able to view them from the new account. The old one does have Firevault activated. thank you for your help ahead of time.