PDA

View Full Version : How can I create a 'gapless' album for iPod/iTunes playback?




omgwut
Jan 14, 2007, 01:32 AM
Hello,
What I mean by gapless is, I have a few albums on my iPod that are full live concert recordings I imported myself, broken up by track. The entire album is seamless straight through, but when one song finishes, there's a gap of about half a second before the next song starts. This is sort of annoying when you want to listen to the concert straight through without interruption.

I downloaded another full live album from the iTunes store before (Rage Against the Machine - Live at the Grand Olympic Auditorium, fyi) and it has no gaps whatsoever between tracks. I want to make my others just like this. How do I go about doing this?

Thanks!



gauchogolfer
Jan 14, 2007, 01:35 AM
Select a track from the album, and hit cmd+i to 'get info'. Go to the tab marked 'Options' and check the box for 'part of a gapless album'. Repeat for all of your tracks.

http://img79.imageshack.us/img79/9274/picture1ys6.png

apfhex
Jan 14, 2007, 02:32 AM
Go to the tab marked 'Options' and check the box for 'part of a gapless album'. Repeat for all of your tracks.
No. That option only makes a difference when you have Crossfade on.

The OP needs to upgrade to iTunes 7, which has gapless playback for all tracks regardless of what you do. If that's not it, then the audio files must have actual silence in them, which would give you gaps no matter if the playback is gapless or not.

gauchogolfer
Jan 14, 2007, 02:41 AM
No. That option only makes a difference when you have Crossfade on.

The OP needs to upgrade to iTunes 7, which has gapless playback for all tracks regardless of what you do. If that's not it, then the audio files must have actual silence in them, which would give you gaps no matter if the playback is gapless or not.

I am running iTunes 7, btw. I think that you actually have to explicitly tag songs as gapless, and I've also seen it 'sense' which albums should be gapless and make the proper adjustments automatically. For something unique like self-recorded concerts it may be necessary to do it manually.

Chundles
Jan 14, 2007, 02:55 AM
I am running iTunes 7, btw. I think that you actually have to explicitly tag songs as gapless, and I've also seen it 'sense' which albums should be gapless and make the proper adjustments automatically. For something unique like self-recorded concerts it may be necessary to do it manually.

Yep, this is the correct answer. iTunes analyses the songs in an album to determine if a certain sound profile is carried across the gap between sequentially numbered songs. If it does then iTunes will tag it as gapless automatically.

You can set an album as gapless by ticking the box in the Info section when you do a "Get Info" on the album.

apfhex
Jan 14, 2007, 03:34 AM
Like I said, the "gapless" checkbox only applies if you're using the crossfade option.

Some CDs, such as live concert albums and classical albums, are meant to be played straight through, with no fading between the songs (or tracks). If you turn on Crossfade Playback, you can have iTunes turn it off when you play these albums.

All of my tracks play "gapless" with iTunes 7, regardless if there's silence at the end of the song (that is, if the song wasn't originally meant to be gapless). It's pretty noticeable compared to previous versions.

RoboCop001
Jan 31, 2007, 11:20 AM
It doesn't seem to be working for me.

I have 2 tracks that are supposed to play right after the other, but the way they were given to me was with a fade at the end of track 1 and at the beginning of track 2. I manually checked the "gapless album" box, but when I test it and put the play position at the end of track 1 (the tracks are an hour long), it just goes to another track.

Would it be that it sees the fading and ignores the gapless box? Or maybe it's because it's in a playlist with lots of other tracks? I have shuffle turned on, but it had no effect when I turned it off.

I've got the latest iTunes.

Do I have to turn on Crossfade Playback? That sucks if that's the only way to get it. It should work without that having to be on.

Also, it doesn't work even with tracks that do not have a fade at the end. I just imported an album that has no silence anywhere, and checked the Gapless Playback box, but it still goes to a different track.