PDA

View Full Version : iBook G3 won't charge!!




macgeek77
Mar 14, 2007, 07:14 PM
My iBook G3 800 MHz will not charge any more all of a sudden. I have tried plugging it in to several power sockets and it won't charge. Whats more... I tried charging it with just the normal charger, and I even tried charing it with the extension wire! I am not sure if it is the charger, or my iBook. If it is the iBook, should i rip it open and get a new part for it? If it is the charger, where can i get a new one? Thanks!!



bigandy
Mar 14, 2007, 07:30 PM
It would help if you knew someone with a similar charger, which you could borrow just to test to see if your iBook charges with it.

If so, just get a new charger. If not, then you know you've got bigger problems. That would be your first port of call ;)

Nukemkb
Mar 14, 2007, 08:25 PM
Be kind to your iBook! The 800 mHz is especially a nice one! Hope you resolve your problem - and please post what it WAS!

Bill Gates
Mar 14, 2007, 10:28 PM
It could be one of several things, such as the power adapter, the battery, or the PMU. If you know someone with any of those parts that are compatible with your iBook, try swapping them for testing purposes to verify which part is the culprit.