PDA

View Full Version : PowerBook G4 Squeaking/Scratching/Buzzing Noises




Medley
Apr 3, 2007, 12:33 AM
Hey Everyone, thanks for reading my post and for any advice you ca give. I have a PowerBook G4 15" Laptop and it's recently started making a buzzing noise. It drives me crazy! The noise seems to come from the processor and happens whenever I'm scrolling through web pages, hovering over my dock, launching applications or pretty much whenever the computer is doing anything.

I've googled the issue and found it to be quite common, even being some posts on this forum. Here's the best info I've found so far:

"The squeaking is actually the processor going into Nap mode, and has been noticed on a number of G4 and G5 models. To save power when the processor has a little bit of idle time, it essentially turns itself off. What is happening when it's squeaking like this is it is alternating very rapidly between going in and out of Napping as the processor waits for more things to do. I've noticed that it happens most often during an active SSL connection; an https:// connection, Software Update, checking E-mail on a secure server, or any other secure connections can make this squeaking noise. There are many other ways to produce it too, such as scrolling through a web page or some other more graphic-intensive process.

If you want to check and/or get rid of it, you can download the CHUD tools (part of Apple's Developer Tools, and also available separately). The Processor preference pane (formerly called Hardware) will let you disable Napping, after which point the squeaking should go away. The squeaking also goes away if you reduce processor speed by turning Energy Saver processor performance down to Reduced. However, I'd recommend that you leave Napping enabled (to reduce heat output and increase battery life), so leave it in the default state."

I've downloaded the CHUD tools program and turned off Nap mode, I think. But it still makes the noises! I cannot figure out how to reduce processor speed. So frustrating. Anyone have any advice?



deadpixels
Apr 3, 2007, 12:41 AM
System preferences / Energy Saver / Options / Processor Performance / you can choose between Normal, Highest or Reduced.

Medley
Apr 3, 2007, 04:40 AM
Hmm, I've tried each of those settings and they have had no affect on the buzzing noise. Still here, still going crazy...

Medley
Apr 3, 2007, 02:56 PM
Strange... now it's stopped. Out of no where. Weird, but thank god, I was loosing my mind trying to get work done. I'm afraid it might happen again or might be an early sign of processor failure. I'd still love some assistance if anyone has any more information regarding this matter.