PDA

View Full Version : MacBook and Warcraft 3 - some mouse issues




fan.of.M
May 17, 2007, 12:53 PM
Hi!

I just installed Warcraft 3 and The Frozen Throne on my new 2GHz 2GB MacBook, patched it etc. but i have a problem with my mouse. When running in windowed mode everything is just fine but when in fullscreen the cursor lags behind bigtime.
Sometimes the OS X cursor shows up aswell but that's not a problem because with Apple-M and Apple-M again the OS X cursor is gone but when it's there I can see how much the Warcraft 3 cursor (i.e. the hand/ claw) really lags behind. As I said, only in fullscreen mode. Any suggestions? Searched all the Internet for this problem but nothing found...
Thank you!



Littleodie914
May 17, 2007, 01:05 PM
Hi!

I just installed Warcraft 3 and The Frozen Throne on my new 2GHz 2GB MacBook, patched it etc. but i have a problem with my mouse. When running in windowed mode everything is just fine but when in fullscreen the cursor lags behind bigtime.
Sometimes the OS X cursor shows up aswell but that's not a problem because with Apple-M and Apple-M again the OS X cursor is gone but when it's there I can see how much the Warcraft 3 cursor (i.e. the hand/ claw) really lags behind. As I said, only in fullscreen mode. Any suggestions? Searched all the Internet for this problem but nothing found...
Thank you!I have the same problem. The mouse does feel waaay slow, it's hard to actually select units, you never know where the cursor is going to end up! :D

I actually resorted to installing it on my PC (a separate box) and have been playing it that way without a hitch. If I can't find a fix, I might just uninstall it from the Mac side and put it under Bootcamp.

fan.of.M
May 17, 2007, 04:35 PM
I've read the whole Thread about the 1.21 patch and lots of people here got the same MacBook as I have but don't complain about such issue... That makes me think... Unfortunately I don't have Windows anywhere here...

QCassidy352
May 17, 2007, 07:02 PM
I have a macbook and play war 3 on it in OS X. I have no issues at all. Have you tried messing with the mouse tracking settings both in warcraft and in OS X system preferences?

fan.of.M
May 17, 2007, 08:00 PM
Yep, I did. But that all just brought me to the conclusion that it has to do something with either graphics or a Warcraft internal mouse driver (or "movement interpreter") that is, in both ways, ONLY active when I'm in fullscreen. As I said, when I run the game in a window the mouse runs smoothly and doesn't lag at all.
Where can I mess around with OpenGL settings and perhaps other graphics drivers in OS X? I'm quite experienced with computers/ drivers in general but not on OS X. I couldn't find a preference panel or something for OpenGL where I can adjust VSync and all this stuff.

statikcat
May 17, 2007, 11:18 PM
No problems but I am on a Pro..

RedTomato
May 18, 2007, 02:51 AM
Just to let you know, I ran WC3 fine on a PB 1.5ghz, both fullscreen and windowed tho I had to turn some of the graphics down a bit. So it's nowt t'do with your processor speed. Make of that what you will.

Littleodie914
May 23, 2007, 08:04 PM
Bit of an update, I think the cursor lagging is due to the high resolution. I switched from the standard 1280x800 to 1024x640 (i think) and it fixed it completely. :D Give it a shot.