PDA

View Full Version : New G4 and Boot disks


evildead
Aug 22, 2001, 11:17 AM
I couldn't decide whether to post this in the hardware or the software section so sorry if I put this in the wrong place. I recently got an 867 Quicksilver and installed all of my old apps. I was having some software conflicts so I thought I should boot off my homemade OS 9.2/TechTool Pro 3.0.4 CD. But it would not Boot. I tried the original TechTool disk that has OS 9 on it. But still failed. I thought maybe it was a problem with the drive so I tried to boot off the Apple restore CD and it worked fine! It appears that Any OS older than 9.2.1 does not know about the latest G4 hardware and yells about it at boot. I guess it makes sense; I had the same problem with and older build of Solaris 8 and the Spark III. It also seems that OS 9.2.1 needs more stuff from the system folder to boot off the CD. I have almost made a new system disk that wont crash. I can get almost to the end of the progress bar but I had to waste 4 CD-R's to get that far. Any one else has the same problem? Any one successful at making a working boot disk?

john123
Aug 22, 2001, 12:25 PM
That it fails at the end of the CD burn is weird. But yeah, your problem is really common. Basically, whenever Apple introduces new hardware, previous SSW won't work on it...so, if you bought a PowerBook G4, for example, an OS 9.1 CD won't boot it -- even though 9.1 is what came on the PowerBook!

The approach I would recommend is to startup from the Restore or SSW CD that came with your computer, and then make a copy of your existing System Folder on your HD. (You can't do this when you start up from the HD because items in use won't copy, like the Finder and stuff). Then, burn your copy onto a new CD, along with whatever else you want. Make sure to tell Toast that the CD needs to be bootable.

Alternatively, you could just use the System Folder on the Restore CD, although that is a minimal (read: crappy) System Folder.