PDA

View Full Version : FTP through Terminal ?




fab5freddy
Jul 9, 2007, 02:34 PM
i would like to learn how to FTP through the Terminal..
what are the commands to do this.. ?

thanks.



kainjow
Jul 9, 2007, 02:41 PM
Type "man ftp" in Terminal.

fab5freddy
Jul 9, 2007, 02:45 PM
ok, then what ?

kainjow
Jul 9, 2007, 02:50 PM
"man ftp" gives you the documentation for the ftp command. Read through it to find out how it works. Or read something like this (http://remus.rutgers.edu/faq/ftp.html).

ChrisBrightwell
Jul 9, 2007, 03:12 PM
Alternatively, you can type "ftp" in at the command line, then use the "?" command to display a list of all available commands.

odinsride
Jul 9, 2007, 03:15 PM
Why not just use something like Cyberduck?

Sure, you can do it through the terminal, but why would you want to? It's a pain in the ass if you ask me.

MongoTheGeek
Jul 9, 2007, 06:11 PM
Why not just use something like Cyberduck?

Sure, you can do it through the terminal, but why would you want to? It's a pain in the ass if you ask me.

Its so much easier in my book, usually faster too if you know what you are looking for.

ChrisA
Jul 9, 2007, 06:33 PM
Type "man ftp" in Terminal.

I prefer "lftp" now. While "ftp" come standard of every computer yo have to hunt down lftp but it gives you syntax very much like the csh shell. It has bash-like history, comand completion and so on. feature wise it adds two things I use (1) A "mirror" command to move entrire directory trees and (2) multiple transfers in parallel. lftp can also access http servers so yu can hve the same comand line access to files on web servers as on ftp servers. Using the mirror command on a directory is a quick way to pull down a local copy of a web site even if you don't have FTp access to it.

But the Mac has an FTP file system built in does not not? So any normal commands on local files should work on remote FTP servers too.

kainjow
Jul 9, 2007, 07:20 PM
But the Mac has an FTP file system built in does not not? So any normal commands on local files should work on remote FTP servers too.

It's read-only, IIRC.

mr666
Oct 18, 2011, 03:48 AM
To fab5freddy:
Isn't it funny that people won't simply answer the question? I know: "Teach a man to fish". But just give the dang answer, OK?

Yes, I know it's too old, but someone has to stand up to these "Look it up" answers. It seems pedantic and pompous.

jiminaus
Oct 18, 2011, 04:09 AM
To fab5freddy:
Isn't it funny that people won't simply answer the question? I know: "Teach a man to fish". But just give the dang answer, OK?

Yes, I know it's too old, but someone has to stand up to these "Look it up" answers. It seems pedantic and pompous.

Don't ya hate it when someone necros an ancient thread just to make a stupid comment on it. ;)

macluva18
Jan 23, 2012, 10:31 PM
New question under same topic:

I'm teaching myself bash, ftp, ssh, etc. I have been able to ftp various servers and 'get' and 'put' test files. My hang up is trying to connect to another computer. I have been testing my skills on my gf mac. I have done all i know to do to ensure that both computers and connect. i.e. turning off the firewall, enabling passive ftp, checking remote manage/login. But when i try to connect, it tries, and the times out.

ideas?

Sydde
Jan 23, 2012, 11:55 PM
New question under same topic:

I'm teaching myself bash, ftp, ssh, etc. I have been able to ftp various servers and 'get' and 'put' test files. My hang up is trying to connect to another computer. I have been testing my skills on my gf mac. I have done all i know to do to ensure that both computers and connect. i.e. turning off the firewall, enabling passive ftp, checking remote manage/login. But when i try to connect, it tries, and the times out.

ideas?

Make sure hers is running the appropriate daemons. You can, for instance, serve web pages right off your computer if you can hand out a stable IP address, but the other computer will get no response if you are not running Apache (httpd). I think you can set most of this up in the Sharing prefpane.

jiminaus
Jan 24, 2012, 01:00 AM
Do you have any devices doing network address translation (NAT) between the computers, for example, an ADSL modem?

Is the IP address of either host a private IP address (http://en.wikipedia.org/wiki/Private_IP_address)?

macluva18
Jan 24, 2012, 01:36 PM
Do you have any devices doing network address translation (NAT) between the computers, for example, an ADSL modem?

Is the IP address of either host a private IP address (http://en.wikipedia.org/wiki/Private_IP_address)?

No i don't believe so. I have a router on my end, ISP, then a router on her end.
And as for the IP, i have tried both. One was a personal address like you would set up on a LAN. the other i got from "whatismyip." same result from both. A time out.

@Sydde: Good call. I had remote login and management checked, but i don't believe Web sharing was. I'll try that on my next attempt.

subsonix
Jan 24, 2012, 02:13 PM
What are you actually trying to do, login to a remote computer or have your computer accept remote logins?

The computer you are trying to login to must obviously run a ftp or (sfpt) server, or you will time out with no response.

lloyddean
Jan 24, 2012, 02:20 PM
You may be interested in learning about 'curl' as well, or in instead.

jiminaus
Jan 24, 2012, 02:22 PM
No i don't believe so. I have a router on my end, ISP, then a router on her end.
And as for the IP, i have tried both. One was a personal address like you would set up on a LAN. the other i got from "whatismyip." same result from both. A time out.

Oh, yes you do. If your computer's IP address is not the same was whatismyip, then at some point something is translating your local private IP address into your public IP address and back again. This will be your router.

Assuming you only want to connect from your computer to her computer (and not vice-versa), you will need to setup port forwarding on her router so that FTP connections to her public IP addresses are forwarded across her router to her local private IP address.

subsonix
Jan 24, 2012, 02:27 PM
In the mean time, try to connect to a public anonymous ftp to confirm. For example:


ftp -a ftp.freebsd.org


Edit:

Or as jiminaus mentioned your NAT is preventing you from connect to port 21, enable port forwarding.

chown33
Jan 24, 2012, 02:45 PM
... I had remote login and management checked, but i don't believe Web sharing was. I'll try that on my next attempt.

Web Sharing is not FTP.

To enable the FTP server, select File Sharing, click the Options button, and check "Share flies and floders using FTP". Then when you check File Sharing, it will start the FTP server daemon. (These instructions are for 10.5 or 10.6; it may differ for 10.7 (not tried), and definitely differs for 10.4 (which has a separate "FTP Access" item).)

You can check that FTP is being served using a program like CyberDuck or Transmit. Or use the ftp command-line on the localhost. Or use the 'curl' command with an ftp: URL. Or use the ftp command-line from another computer on the same network (e.g. you're at your gf's place and connected to her network). You must use the private-network address, not the public-internet address.

Or get Bonjour Browser.app (google it) and see if it sees the FTP service being advertised by the computer where you turned on FTP file sharing.