PDA

View Full Version : iBook... Are you dead?




balofagus
Jul 17, 2007, 08:22 AM
The Problem
Basically, the iBook G4 (last revision) will not turn on.

What is happening
I press the power button, the iBook chimes, HDD makes its regular "computer was just turned on" noises and then the computer sits at the Grey Screen and the little swirly loading thing comes up and nothing else happens.

What happened before the issue
I was browsing the web last night and before turning it off for the night I ran MainMenu's batch tasks. I have been using MainMenu for several months with zero issues up till now. My sister said she needed to use my computer for a few minutes so I turned it back on. It sat at the Grey Screen for 15 minutes so I force shut down and tried again. After another 15 minutes I went to bed (it was getting late) and left it to see what happened over night. Somewhere in my 8 hours of sleep the computer gave up and turned itself off.

I have not heard any tell-tale signs of an HDD failure - no clicking, buzzing or scratchy noises.

Possible Culprits
UNO - has been installed for over a month but it does have access to system files so I'm not clearing its name.
MainMenu - Been using for a while but it was the last thing I did before the problem arose.

What I've done to fix it
- Reset the PMU by pressing Shift + Option + Control + Power Button
- Boot off restore disk and repaired the disk in Disk Utility. The volume bit map and volume information needed repair.


So... is the poor sucker dead?



Mitthrawnuruodo
Jul 17, 2007, 08:36 AM
The volume bit map and volume information needed repair.Did you repair them...? And continue to run the disk repair until it reported "No errors"...?

balofagus
Jul 17, 2007, 08:40 AM
Yup, I even ran it a second time and no errors were reported

Mitthrawnuruodo
Jul 17, 2007, 08:52 AM
Note that after deleting all caches with MainMenu the first restart always is very slow, because a lot of system caches has to be rebuild, I presume, so there is a slight chance you've interrupted it too soon and maybe it will come up if you give it enough time...

But if that doesn't work and if you have current backup of your data (i.e. don't have to try to rescue what's on the disk) you might try a reinstall since you're able to boot from the install disk and obviously have some kind of connection to the HD...

I would see if it's possible to do an Archive and Install first (which should preserv your data), and failing that: an Erase and Install...

balofagus
Jul 17, 2007, 11:23 AM
Thanks very much Mitthrawnuruodo :D. It's back to work perfectly after an Archive and Install. I had a backup from last week so Erasing would have been fine but I had a few (non-essential) files I wanted to keep. Thanks very much, next time I'll pay closer attention to what MainMenu is up to.